Not able to add remote Unix servers in Sitescope

Hi Folks,

 

I am trying to add remote Unix server in sitescope using the SSH v2 communication technique using the monitoring account id(which is already added on the remote server). I am using the keyfile authentication instead of password authentication).

 

When i run the monitor it gives the error that ssh v1 and v2 failed on the remote server.

 

As part of troubleshooting i tried to ssh on the remote server from the sitescope server and it works fine. Not sure why it is failing from the console.

Tags:

Parents
  • Hi,

     

    The private key goes in the SiteScope/groups directory and the public key in
    the <USER_HOME>/.ssh/authorized_keys files of the remote machines.
    The key generated from Mindterm is in Openssh format.

     

    Did you complete this step? Did you use mindterm to generate the key or something else?

     

    Here's an old doc with step by step instructions.

  • Hi Kenneth,

     I got it to work without using mindterm.  As long as you create a private keystore and its corresponding public file it should work. You keep the private keyfile (<username>.priv) and have the customer put the public key (<username>.pub) in their servers authorized_keys. 

    In a nutshell I mimiced what the the instructions did.. 

    On SiteScope I put the <username>.priv in the <SiteScope>/groups (It says name it to identity, but I needed it to be more specific)

    In the Remote Servers section:

    Main Setting
    Username - <username>
    Password - passphrase for keyfile you created for private keystore <username>.priv
    Method SSH

    Advanced Setting
    SSH athorization method = keyfile
    Keyfile for SSH connections = <SiteScope>/groups/<username>.priv --location of the <username>.priv file
    SSH v2 checked

    on the remote server:

    create the remote user

    -#~usradd <username>      - adds the user
    -# mkdir /home/<username>/.ssh   -makes the .ssh directory
    -Copy the public keyfile to the .ssh directory
    -# chmod -R u=rwX,go= /home/<username>/.ssh - set directory permissions
    -# chown- R <username>:<username> /home/<username>/.ssh - changes ownership
    -# su - <username> - assumes roll as the user
    -# cat <username>.pub >> authorized_keys - places cert in authorized keys


    Hope it works for you too. :)

     

Reply
  • Hi Kenneth,

     I got it to work without using mindterm.  As long as you create a private keystore and its corresponding public file it should work. You keep the private keyfile (<username>.priv) and have the customer put the public key (<username>.pub) in their servers authorized_keys. 

    In a nutshell I mimiced what the the instructions did.. 

    On SiteScope I put the <username>.priv in the <SiteScope>/groups (It says name it to identity, but I needed it to be more specific)

    In the Remote Servers section:

    Main Setting
    Username - <username>
    Password - passphrase for keyfile you created for private keystore <username>.priv
    Method SSH

    Advanced Setting
    SSH athorization method = keyfile
    Keyfile for SSH connections = <SiteScope>/groups/<username>.priv --location of the <username>.priv file
    SSH v2 checked

    on the remote server:

    create the remote user

    -#~usradd <username>      - adds the user
    -# mkdir /home/<username>/.ssh   -makes the .ssh directory
    -Copy the public keyfile to the .ssh directory
    -# chmod -R u=rwX,go= /home/<username>/.ssh - set directory permissions
    -# chown- R <username>:<username> /home/<username>/.ssh - changes ownership
    -# su - <username> - assumes roll as the user
    -# cat <username>.pub >> authorized_keys - places cert in authorized keys


    Hope it works for you too. :)

     

Children
No Data