How to change Hostname in VPV 1.20?

My customer has deployed HP vPV 1.20 Appliance (CentOS box), they would like to configure the Hostname.

 

I did not find how to configure Hostname in vPV Appliance, I checked vPV manuals. But no luck.

I tried following without success :

 

/opt/vmware/share/vami/vami_set_hostname vpv.lab.local

 

Please suggest.

 

Regards

Smita

  • I presume you are using the virtual appliance and running vPV.

     

    If so, it is a CEntOS linux. Nothing specific that vPV is doing to prevent or assist you in setting  a hostname.

     

    vami scripts are provided by VMware for use with virtual appliances.

    this should work in short. :)

     

    Question: something is failing for you - can you describe what this is?

     

    If you run the vami_set_hostname script, and reboot the appliance, is the new hostname not getting reflected?

  • Verified Answer

     

    You may use the VAMI (Virtual Appliance Management Infrastructure) interface to change the hostname and other settings.

     

    You can access this interface via https://[vPV_System_IP_address_or_Hostname]:5480/

     

    - Login as root.

    - Go to "Network".

    - Go to "Address" tab.

    - Enter new hostname and save settings.

     

    Hope it helps.

     

  • Hello Pranesh,

     

    Thanks for your suggestion.

    It worked.

     

     

    Regards

    chirasmita

  • Dear,

     

    Using the VAMI (Virtual Appliance Management Infrastructure) interface is possible to change the hostname, however when you reboot the system it will go back to "localhost.localdom".

     

    The only way I found to change the hostname permanently is:

     

    1. Open the script vami_set_hostname, located at /opt/vmware/share/vami;

    2. Change the line HOSTNAME to desired hostname (see pic below).

    3. Restart the server.

     

     

  • Hi. I had a similar experience, when clicking "Launch Cloud Optimizer Virtual Appliance Management" returned an error. This could be because the URL was pointing to https://<fqdn>/PV/html/ui/settings/html/:5480. When I changed the URL in the web browser to https://<fqdn>:5480, it worked. Thanks. Is there a way to change the URL in the default CO UI?