Video: Robotic Process Automation (RPA) Installation - Authoring Environment

1 Likes
over 1 year ago

This video contains the steps to install RPA components required for creating workflows and recording screen elements.

NOTE: This video contains no audio.

Watch Video

Tags:

Labels:

Videos
Comment List
Anonymous
  • Hello ,


    Please find below idm-service.log after login attempt.
    It says authentication is succeeded, then Why '401 Unauthorized'; error is coming.

    idm-service.log...
    2020-10-05 13:04:13,275 [https-jsse-nio-8445-exec-4] INFO com.hp.ccue.identity.filter.RequestTokenFilter - idm auth group: AuthGroup{organization=RPA, name=defaultauthgroupname, configurations:1}
    2020-10-05 13:04:13,276 [https-jsse-nio-8445-exec-4] INFO com.hp.ccue.identity.filter.RequestTokenFilter - idm auth flow: [SEEDED, DATABASE_USER, LDAP, JAAS, AD]
    2020-10-05 13:04:13,344 [https-jsse-nio-8445-exec-4] INFO com.hp.ccue.identity.filter.certificate.CertificateFilter - doFilter()
    2020-10-05 13:05:48,604 [https-jsse-nio-8445-exec-10] INFO com.hp.ccue.identity.web.api.AuthenticationController - Start authentication for organization: RPA
    2020-10-05 13:05:48,617 [https-jsse-nio-8445-exec-10] INFO com.hp.ccue.identity.authn.MultiTenantAuthenticationProvider - The authType is [SEEDED, DATABASE_USER, LDAP, JAAS, AD]
    2020-10-05 13:05:48,857 [https-jsse-nio-8445-exec-10] INFO com.hp.ccue.identity.authn.MultiTenantAuthenticationProvider - Authentication succeeded for user admin in organization RPA

    Regards,

    Ashish

     

  •  the information from this log is not sufficient. Can you please check also the idm-service.log from the same folder?

    It would help if you also provide the messages that are displayed after your login attempt.

    Thanks,
    Florin

  •  , as per your suggestion I reviewed server.log (sharing log below), Reviewing this do you have some suggestion for me..  

    2020-09-25 08:38:07,488 [WrapperStartStopAppMain] (AbstractEventsBuffer.java:48) WARN - Debugger execution events: - init buffer with capacity: 100000, with bulkSize:5000
    2020-09-25 08:38:08,144 [WrapperStartStopAppMain] (LWSSOConfigurationServiceImpl.java:53) WARN - "InitString" cannot be shorter than 12 characters.
    2020-09-25 08:38:08,488 [WrapperStartStopAppMain] (LWSSOConfigurationServiceImpl.java:53) WARN - "InitString" cannot be shorter than 12 characters.
    2020-09-25 12:09:51,420 [https-jsse-nio-8445-exec-1] (OoRpHttpConnectionImpl.java:138) ERROR - Connection response code returned :401
    2020-09-25 12:09:51,422 [https-jsse-nio-8445-exec-1] (OoRpHttpConnectionImpl.java:147) ERROR - Connection response code returned: 401: ‹VJ-*Ê/*V²ŠVJ-,M-.Q(QH­Èæ)d+dæ•%æd¦(ÅÖ ÿÿ -~Ê09
    2020-09-29 10:12:26,517 [WrapperStartStopAppMain] (AbstractEventsBuffer.java:48) WARN - Debugger execution events: - init buffer with capacity: 100000, with bulkSize:5000
    2020-09-29 10:12:27,189 [WrapperStartStopAppMain] (LWSSOConfigurationServiceImpl.java:53) WARN - "InitString" cannot be shorter than 12 characters.
    2020-09-29 10:12:27,564 [WrapperStartStopAppMain] (LWSSOConfigurationServiceImpl.java:53) WARN - "InitString" cannot be shorter than 12 characters.
    2020-09-29 16:15:23,833 [WrapperStartStopAppMain] (AbstractEventsBuffer.java:48) WARN - Debugger execution events: - init buffer with capacity: 100000, with bulkSize:5000
    2020-09-29 16:15:24,803 [WrapperStartStopAppMain] (LWSSOConfigurationServiceImpl.java:53) WARN - "InitString" cannot be shorter than 12 characters.
    2020-09-29 16:15:25,256 [WrapperStartStopAppMain] (LWSSOConfigurationServiceImpl.java:53) WARN - "InitString" cannot be shorter than 12 characters.


    Regards,

    Ashish

  •  I am suggesting you take a look at the logs in the <installation_folder>/designer/var/logs/ and see if there are relevant errors that might point you in the right direction. 

    It is also recommended that you open a support ticket to get this problem reviewed. It might be a configuration problem.

  • ,

    Yes, I am accessing the OO-designer using https://<fqdn>:8445/oo-designer thats why I am getting login screen. After entering admin credentials, I get 401 error (seems there is no way to share screenshot)

    Thanks - Ashish

  • The URL that you need to access to open the Workflow Designer is https://<hostname>:<port>/oo-designer/ , where hostname should be the server/vm FQDN and the port is the chosen port during installation. By default, the port is 8445.

    Can you please confirm this is the URL you are accessing?

    What RPA version have you installed?

  • Hello  I am trying to logging with admin user specified during designer installation.

  •  can you please specify what user you are trying to login with?

  • Hello,

    I followed the youtube video to install RPA Authoring tools. Tools were installed successfully.
    When I am trying to browse through the oo-designer...

    1) I am prompted the login screen, I enter the same credentials which I entered in the installation wizard. And click Login.
    2) Get "HTTP Status 401 – Unauthorized"

    Can anyone guide, what could be possible root cause of the problem.

    Thanks!

  •  the video only demonstrates how you should install the RPA component. You should not use the same hostnames, users or passwords that are referenced in the video. As a prerequisite, you should install your own database server, which will have it's own hostname / IP address. The logs clearly show that you are using rpa.microfocus.com as your database hostname. This is just wrong, since this value was used to record the demo and you should replace this with your own database server hostname.

    Please refer to the more detailed information on the installation process here: https://docs.microfocus.com/itom/Robotic_Process_Automation:2020.02/InstallCleanDesigner

Related Discussions
Recommended