Discovery of HP SN6500B 96/48 FC Switch

Hello, 

my customer needs to discover and manage 2 HP SN6500B 96/48 FC Switch, 2 HP SN6000B 16Gb 48/24 and 2 HP 8/8 (8)-ports Enabled SAN Switch (AM867B). Is having a Brocade Network Advisor (BNA) server the only possibility? He does not have one.

Thanks

Francesco 

  • Hi Francesco,

    yes BNA is the only way to discover Brocade Switches in SOM. Do not install the BNA on the SOM server. You can use a VM host to run the BNA. Most current version we support with SOM is BNA 14.02. You can download the HP Branded BNA from the HPE support site. BNA has the option to install 'SMI-s only' which is sufficient for SOM. The SMI-s only option will not require a license for BNA (configuration has to be done through the BNA Management console then).
    Let me know if you need some more details.

    Dieter

  • Hello Dieter, I installed HP SAN Network Advisor Pro Plus v 14.2.0 on a different VM and this works fine. It discovered all my switches. Nevertheless I'm not able to discover them from SOM. The error in in the attached screenshot. Thanks Francesco
  • Hello Francesco,

    There are two things that I would check to confirm.

    1. Confirm if port 5989 is open within the local firewall on the HP SAN Network Advisor server.
    2. Confirm that the CIMOM Server is running within the Server Management Console of the HP SAN Network Advisor server.

    If both of these are set properly, then the issue could be an authentication issue or another firewall exists between the SOM server and the SAN Network Advisor server.

    I hope that this helps.

    Regards,

    Mark

  • Hello Mark,

    I confirm:

    1. Local firewall is disabled on HP SAN Network Advisor server
    2. CIMOM Server is running within the Server Management Console of the HP SAN Network Advisor server

    Moreover, as suggested from one of your SW Support collegue, I uninstalled BNA v.14.20, rebooted the server and installed BNA v.14.0.2 but situation is unchanged. I still have the same error. BNA by itself works fine and discovers all the switches.

    Regards

    Francesco

  • Francesco,
    I saw you raised a support ticket for the issue. In the support case it is mentioned how to use the mofexplorer.ovpl command to verify if the BNA Cimom (SMI-s) server can talk to the SOM server. You former log discovery context output showed the port 5989 on the BNA server is not responding. You might also double-check on the BNA Server from a command prompt if the BNA is listening on port 5989 and what task is behind. If the BNA Server has multiple IP Addresses you might configure in the BNA Management Console the proper IP. From a command prompt on the BNA run
    netstat -ano |findstr :5989

    Where you should see the BNA Server listening on port 5989. The last number is the list is the processid. If you run then the command

    tasklist |findstr <processid_from_former_command> you should see the cimomsrv.exe process behind.

    example:

    C:\>netstat -ano |findstr :5989
      TCP    172.10.10.104:5989    0.0.0.0:0              LISTENING       3036
    C:\>tasklist |findstr 3036
    cimomsrv.exe                  3036 Services                   0    247,420 K

    In case your BNA server has multiple active IP Addresses make sure BNA is listening on the correct one. Start BNA Server Management Console, select Configure SMI Agent, login and select the 'Cimom' Tab. Adjust the Binding Address if required
    (see screenshot1a).
    Also make sure no additional Authentication has been enabled under the 'Authentication' tab (see screenshot2).

    Regards,
    Dieter

     

     

  • Hello Francesco,

    If there are no active firewalls between the SOM server and the BNA server and the CIMOM on BNA is running, then I would suspect that there may be an authentication issue.

    The issue at this point is that SOM is unable to communicate with BNA.  It uses port 5989 and the CIMOM server service for this communication.  Sometimes I have seen where the discovery will fail with no error messages if it is an authentication issue.  The default credentials are "administrator" and "password" unless you have changed them.

    You may try using the mofexplorer command to see if you can successfully communicate with the SMI-S (CIMOM server) for BNA from the SOM server.

    mofexplorer.ovpl -h https://<bna server url> -l Administrator:password -n /root/brocade1 Brocade_switch

    where mofexplorer.ovpl is located in the %OvInstallDir%\bin directory on Windows or /opt/OV/bin on Linux.

    This command above should list all of the switches that are discovered by BNA.

    I hope that this helps.

    Regards,

    Mark

  • Verified Answer

    Just for those who follow the thread .. it turned out that in Francesco's case, the Binding Address, configurable within BNA, was set to a different IP Address. So the IP being used to to discover the BNA in SOM failed.

    Adjusting the Binding Address within the BNA Management Console (SMI-s Part) or using the the 2nd working IP Address in SOM to discover BNA (if network routing is setup properly)  fixed the issue.

    Regards,

    Dieter