Routing SMTP through AssetCenter Server

Is there a way to route all SMTP messaging through one machine before it tries to access the Exchange server?

We are running AssetCenter 4.4.2 in a Windows environment. The messaging team is looking at upgrading the Exchange servers to 2007, but when that happens they have to hard code a list of approved senders for SMTP. This won't work if we have to hard code each client, so I've been asked to see if we can route all messaging scripts through the server and then hard code the server's address in the approved list for the Exchange server.
  • Matt: How are you sending messages right now? If you are going through workflows, then you can set the workflows to be run on server...this way it will not execute right away, but get queued up and sent via your server. This way all messages get sent through a single server.

    Another option is set up the internal messaging and then use Connect.it to pick them up and send them out...after you are done with that have Connect.it mark them as read.

    Hope that is what you are looking for.
  • You can modify the win.ini file placed in C:\Windows
    Modify the contents of SMTP settings

    [Mail]
    SMTP=1
    SMTPserver= Put the server name here
    SMTPport=25
    SMTPtimeOut=20
    email=aks@gmail.com
    displayname=Akhil Singh

    so this way all the email will be getting executed from the server.
    Hope this will work out for you
  • Nice answer Akash. Matt, I'd go with the moving the sending to the server. Just be sure you tell everyone that when their message is sent, it may take about 10 minutes or so before it actually goes out (next cycle of the AC server).

    If they are coming from a wizard, it might get a bit more involved. I don't recall if any of them were being sent that way or not, but if they were, you might look at having the wizard trigger a workflow somehow instead of sending the mail directly. Might be able to do that by writing the info to a custom table instead of sending it. I think you could do something that way to get the mail sent by the server instead of the client.

    Michael
  • Well, as of last week this became a moot issue. There were other applications in the environment that were having the same issue so the messaging team has found another way around the issue.

    Thank you for all of your thoughts though.