How to give "Filter on this field" option in profile/role or similar to Administraton rights profile

Using AM Windows client, if a user has "Administration rights" ticked in Profile. Then they can see/use the "Filter on this field" option (Right Click on a field).

How can we enable users with custom Profiles/Roles to have this option?

Also I would like to create a custom profile similar to "Administration rights" profile...how do I go about that?

TIA!

  • I have never seen "Filter on this field" NOT available for everyone.  Can you please confirm this option is not listed anywhere on the right-click list?  Does the table in question have records?  Please supply screenshot if it is really missing.  Besides, default toolbar 6th position is for Filters where a Simple filter does same (just without field SQLName auto-populated).

    There is no way to create a custom profile similar to "Administration rights" profile.  Any employee record can either have the 'Administration rights' flag checked or not.  BE CAREFUL:  when checked this gives that employee record full access to the entire AM application.

    NOTE:  When this flag is checked, see right side of Profile section under Profile tab, the 'Role used at connection' and 'Authorized user roles' disappear.

    The only way to come close to Full access is to create a security role having full user (RIU/CD)/functional (GRANTED) rights for the 'Role used at connection' and 'Authorized user roles'.

  •  

    Hi Mark,

    I create a profile (MyFullAccess) and given it:

    User Rights: Full Visualization,General Full access (OOTB rights)

    Functional Rights: General full access (OOTB functional rights)

    Assigned it to a user, set the Authorised User roles and Roles user at connection accordingly.

    I logged in as this user, and i dont see the Filter on this field option. Please see attached am-user.png.

     

  • Thank you for the screenshot.  Again, I have never known this to be user security related.  Can you please confirm 'File > Managed modules' menubar option shows all enabled (ie. not greyed out).  Is this against a calculated field?  You may have to re-install AM and/or contact Micro Focus support.

  • My apologies.  I will not be able to help with this.  I was able to identify same issue so this may relate more with "where" the field is located (which table) or how it is displayed on the screen/page.  For the most part the Filter toolbar option can be used instead of right-click.