How to connect and execute ALM Test Cases from HPOO

Hello,

We would like to execute 'Test Cases' in ALM (Version 12.55) from HPOO (Version 10.70).  Is possible?
In HPOO we have integrated the 'Content Pack' Micro Focus Solutions [2.0.1] to have access to the 'Application Lifecycle Management' libreries, but we do not find any module that explicitly indicates 'Execute Test Case'.

Once we got connected to ALM (through the module 'Get Lightweight SSO Token'), when trying to execute then any other module of this library in HPOO (from Test Lab, Test Plan, ...) we always get the error: PAGE_NOT_FOUND
For example:
<body><h2>HTTP ERROR 401</h2>
<p>Problem accessing /qcbin/rest/domains/SEAT_E_PROD/projects/ADMINTOOL/customization/entities/run/fields. Reason:
<pre>    Authentication failed. Browser based integrations - to login append '?login-form-required=y' to the url you tried to access.</pre></p><hr><i><small>Powered by Jetty://</small></i><hr/>
</body>

It is possible to tell HPOO that the resulting URL ends in: '?login-form-required=y' ?, or tell us what we are possibly parameterizing wrong?

Is there some kind of documentation for this interconnection?

Thank you very much for your help and to excuse our ignorance.

  • You need to grab a token or session and use it for subsequent calls as far as o remember. There is a specific operation for that. I should have some sample integrating with alm somewhere. Will look for it tomorrow.

    It is an authentication problem as I see it.

    As far as I know apart from the operation's description there is no other document talking specially about this integration.
  • A long time ago I used the sequence of steps as seen below in the screenshots and it used to work.

    If you did not succeed it by now, I hope the info will help.

    Screenshot_14.pngScreenshot_13.pngScreenshot_15.png

  • We had the same problem. In this case there're 2 main problems:

     

    - Connection problem --> we solved it adding the "create session" operation in order to lwSsoToken.

    - Execute test case operation is not available --> we're looking for an alternative to "execute test set" because this operation is missing.

     

  • Hi,

    Are these QTP/UFT automated tests you want to execute?

    If yes,  in the past I was able to do this by creating a custom operation (there is none available out of the box) that was calling (using Remote Command Execution operation) an QTP/UFT comman line (CLI)client. that triggered the test execution in ALM. The UFT/QTP CLI client was provided by support team. It worth asking if the CLI still exists.

    HTH,

    Lucian