How to escape slashes in JRSFlowInvoke command construction?

Anybody is aware, how to avoid call REST errors, when passed value contains slash? E.g. in below line, the call will fail with an error: "path not found" . Note: I replaced all vars by fake values :).


java -jar "C:\Program Files\Hewlett-Packard\Operations Orchestration\Studio\tools\JRSFlowInvoke.jar " -u USER -ep ENCRPTPASS "">SERVER:PORT/.../FLOWUUID


Anybody knows? Thanks.


  • Hi,

    This is a general error. Where are you getting this error? After or before the connection? Or when trying to connect?
    It might be cause of firewall or port settings. Have you checked the connections with telnet? Check it manually from the host machine, and vice versa.
    Check your username and password too.

    One more thing: Check the JVM that you are using.

  • I am sorry was not specific. I used the REST to call flow.
    Flow was running about 8 minuts. So the REST was exited earlier, by internal timeout. I am looking to find how to set it for the longer execution? Hope it's better.


    just added :

    the JRSFlowInvoke.jar which was called a flow returns

    socket error of Connection reset: Connection reset

            at Source)

            at Source)

            at Source)

            at Source)

            at Source)

            at Source)

            at Source)

  • JRSFlowInvoke command returns the flowId within xml format. Is it your first trial with JRSFlowInvoke? First of all try to telnet from host(where you are running the JRSFlowInvoke command) to OO server.
    "telnet SERVER PORT" server : OO server IP , PORT : OO server port (443 or 8443)
    If you cannot connect with telnet there might be firewall settings between machines.

    If you are calling JRSFlowInvoke try to use "-async" parameter, it starts the flow, but returns without waiting for the run to complete. "java -jar JRSFlowInvoke.jar" command on command line helps you about parameters. I think you are getting the return code 5.

    If you want to wait the result of the flow, try the "RSFlowInvoke.exe" instead of jar file. It has "-t [timeout]" parameter(default value is 100 seconds). There is a slight differences between jar and exe commands.

    I am not sure if JRSFlowInvoke.jar has "-t [timeout]" parameter but you can try with this parameter.

    Hope it helps.


    I tried JRSFlowInvoke.jar with and without "-async " parameter. There is an interesting thing. Firstly in my flow, I set the start step "sleep 120 seconds". And JRSFlowInvoke.jar waits 120 seconds for response. And after that  I set the start step "sleep 1 seconds" and JRSFlowInvoke.jar waits 1 seconds for response. The start step of the flow might effects for the response. Check your start step. 


  • Thank you very much!
    Yes, it working with flows the run time of which is less then 5 minutes. I test exe with -t and git the error pretty much the same. But I guess it all related to Central is force to close SSL connection. See error:
    The underlying connection was closed: Could not establish secure channel for SSL
    System.Net.WebException: The underlying connection was closed: Could not establi
    sh secure channel for SSL/TLS. ---> System.IO.IOException: Unable to read data f
    rom the transport connection. ---> System.IO.IOException: Unable to read data fr
    om the transport connection. ---> System.Net.Sockets.SocketException: An existin
    g connection was forcibly closed by the remote host
    at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
  • WOW, I gotcha! The socket error was generated by Central VIP. I test the call by specific Central servers and found: if VIP is used it throwing the error after 300 sec. I apply changes to server admin.
    Thank you all.