Invoke Method 2 / Web Service Wizard - NTLM Authentication

I've been beating my head against the desk today trying to get NTLM authentication working in OO.  I have an asp.net page on IIS7.5 exposing web methods through an asmx.  Windows authentication is required.

 

I used Web Service Wizard to import the WSDL from this page, which prompted me to log in with Windows Authentication using my user/pass/domain.  This worked fine and created the necessary flows for communicating with the web service.

 

I am not, however, able to get authentication working when I call these flows.  The underlying action is Invoke Method 2.

 

Here are what I assume are the relevant inputs for Invoke Method 2

wswAuthenticationType - The authentication type to use for the username and password input. http is default (Uses http authentication), other options are 'ws-security digest' and 'ws-security text' WARNING: ws-security text transmits passwords in clear-text
username - The username to use for authenticating with the web service
password - The password to use for authenticating with the web service

 

I've tried domain\user and user and neither worked.  Authentication is set to http.

 

This is driving me crazy so I'd really appreciate some help from anyone who's gotten this working.  

  • I also tried using the authentication type

    ws-security digest

    with the same results

     

    I tested from my local system with curl and was able to authenticate to the same page with both ntlm and digest, so it is definitely something on the OO side I'm not doing properly

  • Hi,

    What is your OO version? Are you using OO 9.03 ? If not  you should better upgrade your system.

    Here is the Invoke Method 2 parameters of OO 9.03 version.

     

    wswAuthenticationType - The authentication type to use for the username and password input. http is default (Uses http authentication), other options are 'ntlm', 'ws-security digest' and 'ws-security text' WARNING: ws-security text transmits passwords in clear-text

    username - The username to use for authenticating with the web service. For NTLM authentication, the required format is domain\user.
    password - The password to use for authenticating with the web service

     

    Even if you are not using OO9.03, try with these parameters like below:

    wswAuthenticationType : ntlm

    username : domain\username

    password: usernames password

     

    Kind Regards.

     

  • I'm on 9.0.3 but it appears the RAS repository wasn't updated properly.  The operations list NTLM as an accepted form of authentication but when I try to use it I get an error back.

     

    The underlying jar files apparently weren't modified with the patch.  Any tips for getting the RAS repository up to date?

  • Hi,

     

    We had the same problem. If you have any other RAS updated properly, you can try to deploy the folder from that RAS but check out the keystore files first. If you don't have any other RAS you have reinstall like us.

     

    Regards.