Failure WSDL SOAP call with user and root certificate

Hi all,

I have a big issue  using WSDL SOAP call for a customer webservice. I have imported the WSDL using the ws-wizard tool and everything is ok, I need to authenticate the webservice call using the customer certificates. I have received the certificate inside a jks keystore and I have received the root certificate that I put inside another trustKeystore.

Inside the standard OO operation created from the wizard we cannot specify the trustKeystore, so I have tried to use the http client post operation specifying the trustKeystore and the keystore. I have also tried to import the certificates inside the OO cacerts and key.store but there are nothing to do, I got always the SSL handshacking error: "A trusted keystore is not found or it does not contain the needed certificate".

I am using Studio in remote debug Mode inside the Central, that is the only server allowed to call the webservice. I have installed SoapUI in the same server, using the same keystore and the same xml body and it works.

It seems OO is not able to manage this kind of authentication.

Anyone have experience on that topic?

Thanks for your help

Mirco