OO Webpage stays in "redirecting "

Hello everyone,

Central doesn't show login form.. Always appears ths message.


I disable ssl in tomcat and still persist the message.

I Unlocked the loglock table and the same result.

Into the log appears DECRYPT FAILED.

2018-03-20 23:30:33,420 [localhost-startStop-1] (Logger.java:138) INFO - [com.hp.autopassj.core.pdf.ProductDefinitionStore : getProductDefinition] :: Getting Product Definition context with key '/opt/hp/oo/central/var/autopass/20024_1.0_OO_10.5.pd'.
2018-03-20 23:30:33,436 [localhost-startStop-1] (StatisticalLoggingSessionEventListener.java:275) INFO - Session Metrics {
1402246 nanoseconds spent acquiring 1 JDBC connections;
0 nanoseconds spent releasing 0 JDBC connections;
205060 nanoseconds spent preparing 1 JDBC statements;
567239 nanoseconds spent executing 1 JDBC statements;
0 nanoseconds spent executing 0 JDBC batches;
1685973 nanoseconds spent performing 1 L2C puts;
0 nanoseconds spent performing 0 L2C hits;
0 nanoseconds spent performing 0 L2C misses;
0 nanoseconds spent executing 0 flushes (flushing a total of 0 entities and 0 collections);
7885 nanoseconds spent executing 1 partial-flushes (flushing a total of 0 entities and 0 collections)
2018-03-20 23:30:33,438 [localhost-startStop-1] (SymmetricEncryptor.java:106) ERROR - Decrypt failed
javax.crypto.BadPaddingException: Invalid padding.
at com.rsa.cryptoj.o.gc.engineDoFinal(Unknown Source)


Do you have any suggestion? Thanks for your time.



Parents Reply Children
  • If you want to use the existing database, as far as I know, that is the only option.

  • Greetings everyone,

    Sorry for the late inquiry 

    I am having the same problem with a brand new installation as well.

    I preserved the old /var/security/encryption files and copied them to the new 10.50 installation but keep getting:

    You are about to be redirected to HP Operations Orchestration web application

    I have done this in two other new 10.50 installations with 3 central nodes and did not have this problem.

    Other than copying the old /var/security/encryption files to the new installation, is there anything else ( like in Tomcat ) that I need to check or change.?   The only different between this installation and the ones that worked is that this installation only has one central node as opposed to 3, which i had no issues with.

    thanks so much for any help you can provide.

    Regards, Oscar

  •  I didn't really get why you created a new environment and kept the encryption files. you want to point to the same database that was used by the old environment? if yes, you did preserve the database.properties file too right?

  • Hello Andrei , thanks for your reply.

    yes, we kept the same encryption and DB prop files to be able to use the same database in a totally new private cloud environment.  I had opened a case with Microfocus to see if my issue has to do with the fact that I am installing HPOO 10.50 on a single node ( 1 Linux-JRAS , 1 Windows-NRAS )  but I was told the installation is smart enough to know not to activate the high availability feature and only look for one node.   This does not seem to be the case as it appears that something in tomcat is expecting a second node and wants to re-direct to a recond node ( Speculation on my part. ).

    The plan was to install 10.50, using old Database, then upgrade to 10.51, then test workflows to make sure they work and lastly, upgrade to 10.80 and test again to make sure workflows execute properly.

    thank you,



  • Greetings all,

    Just a quick update.

    I am happy to report that this issue has been resolved, however, I am not satisfied with the fact that I still don't know root cause.   

    After working with Microfocus support, they advised rebooting HPOO APP server, followed by HPOO DB server.

    Both servers were rebooted and the looping redirect suddenly is fixed, but waht caused it and how can it be prevented?




  • Hello,

    I had this issue with constant redirecting today, and finally it turned out that my database password had expired.

    So I changed the DB user password as DBA user and then changed it back again so that OO could connect again.

    Best regards,