Build error in Maven while building custom action in HP OO 10.60

I am following the Action Developers Guide and have imported the project into Eclipse. Now when I clean and Compile or install the project, I am getting the below error:

Caused by: org.apache.maven.plugin.PluginContainerException: An API incompatibility was encountered while executing com.hp.oo.sdk:oo-contentpack-maven-plugin:10.60.00-RC9:generate-contentpack: java.lang.NoSuchMethodError: org.apache.maven.execution.MavenSession.getRepositorySession()Lorg/eclipse/aether/RepositorySystemSession;

The below is the compiler version in my pom.xml

<build>
<plugins>
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.2</version>
<configuration>
<source>1.7</source>
<target>1.7</target>
</configuration>
</plugin>
</plugins>
</build>

Is this the problem with the compiler version? I am using Maven 3.2.1 as instructed in the guide. Kindly help me.