HP Service Manager Web Services validations

Hello experts I tried to create incidents via web services in SM 9.41 but I have errors by validations. I disable the validation in the corresponding workflow but the behavior is the same. In where other places exist validation of the fields? I did a couple of tests in a vm with SM 9.40 OOB and the creation of incidents and interactions does not require to populate the mandatory fields inclusive if in the WF has validation rules. Could you help me? Please Best Regards
  • Hello,

    What is the error that you're having with your Web Service or what are the exactly fields where the issue occurs? 

    Normally, the validations should not give any mistake.

  • Hello Robcord

    When I tried to create the incident and I remove the validations I have the next error in the response of web services

    <cmn:message type="String">scxmlapi(19) - Se produjo un error al llamar al Motor de documentos con cc -1 msj:</cmn:message>

    The translation is like

    <cmn:message type="String">scxmlapi(19) - An error occurred to call document engine cc -1 msj:</cmn:message>

    When I able again the validations the message is like the next

    Subcategory has no valid value

    I need for the moment disable the validations and create the incident by web services later I need add conditions to the rules to the web services validate some information

    Thanks

    Best Regards

  • I paste the complete error message form the response

     

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
    <SOAP-ENV:Body>
    <CreateIncidentNGOSSResponse message="scxmlapi(19) - Se produjo un error al llamar al Motor de documentos con cc -1 msj: " returnCode="19" schemaRevisionDate="2019-04-29" schemaRevisionLevel="1" status="FAILURE" xsi:schemaLocation="http://schemas.hp.com/SM/7 ">domain:13080/.../IncidentNGOSS.xsd" xmlns="http://schemas.hp.com/SM/7" xmlns:cmn="http://schemas.hp.com/SM/7/Common" xmlns:xmime="http://www.w3.org/2005/05/xmlmime" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <model>
    <keys>
    <id type="Decimal">209</id>
    </keys>
    <instance recordid="209" uniquequery="id=209"/>
    </model>
    <messages>
    <cmn:message type="String">scxmlapi(19) - Se produjo un error al llamar al Motor de documentos con cc -1 msj:</cmn:message>
    </messages>
    </CreateIncidentNGOSSResponse>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>

  • Verified Answer

    There are several possibilities for where a "validation" is coming from. These include RuleSets on a Workflow, Workflow Phase or Object, as well as Format Control, Validity, and the RAD applications themselves.

    If you have already disabled all potential RuleSets and Format Controls that are relevant to this table, my recommendation is to paste the entire  Web Services request in here so it can be reviewed. Most likely you are missing some kind of required fields to submit the request. There are certain required fields that if omitted will prevent the system from creating the record even if "validations" are disabled.

    Another possibility is that the syntax of the request is incorrect in some way. I have personally run into this issue when using a third party tool such as SoapUI to generate the requests.

  • Hello Mike

    I add the WS in the attachment file

    I notice in the rule that shows me the error that the field to validate has a different type of the imSubcategory name is a string and the field that is validated is a number field in the WS service appears with these attribute

    type="Decimal" 

    I do not find the relation or logical of that comparison

    Thanks so much

    Regards

    WSServiceManagerIM_Test.zip