Is Service Manager compatible with Exchange 2016

Hello:
one customer have Service Manager 9.4 and the version they use of connect-IT is 9.6.
Do we have information to check compatibility with Exchange?
Exchange Server 2010, will be decommissioned on August and they said Service Manager is not compatible with HPSM 2016.
Thanks you very much in advance,
Best regards