Exporting Workflows but can't find phases inside

I am trying to migrate a customized workflow from one Service Manager environment to another (same version), but after importing the workflow, I opened it and can't see any phases inside (the viewer is just empty).

I tried to migrate the records in Database Manager > WorkflowPhase first, and then import the workflow, but still got the same result, no phases inside the migrated workflow.

I exported a customized workflow using below steps:

  1. Navigate Tailoring Process Designer Export Workflow.
  2. In the Export/Unload a Workflow tab, select a Process Designer Table from the Table drop-down.
  3. Select the workflow from the Workflow Name field.
  4. Enter an appropriate name in the External File Name box. (ExportWorkflow.unl)
  5. Select the Append to file check box.

Then I copied the ExportWorkflow.unl file from the server to my desktop, and then import using Database Manager:

  1. Navigate More > Import/Load.
  2. In File Name, browse and select the ExportWorkflow.unl file.
  3. Type an Import Descriptor, File Type=winnt.
  4. Click Load FG.

Can anyone help with this? Thanks a lot!

  • Not the same thing as you're describing but I have had an issue before where after I unloaded a customized workflow the phases and transitions didn't render properly.

    In my case the workflow updates had been applied but I had to restart the web services before it looked correct.