SM9.4 - cant search "action" in probsummary...

I am not sure what is going on with this tool. I am using the default field "action" in probsummary and it is an IR key - i did not change this from out of box. I cant search for any term in the action field. in the search there is the 2nd tab that you can change how the search is done from "these words" or "any words" and I have tried using the * symbol before and after my term. I have created new records with my specific term for testing and it I just cant get it find the record.

 

I dont think it has ever worked. Is there something I need to turn on if this an out of box installation? what is the purpose of this tool if you cant search on the one field that stores the most vital information for incidents???

Tags:

  • i rebuilt the IR index for probsummary - still no results from keywords in the "action" field of probsummary.

    I tried to search using "Search Knowledgebase" and selecting everything - still no results from keywords in the "action" field of probsummary.

    I can see ir.probsummary records in SCIREXPORTM1 table (only a handful of records)

    I do not have any "ir_asynchronous" settings in SM.INI

    I dont see any " (IRQUEUE) " job running when I go to "System Status" of service manager (not sure if it is supposed to be there"

    It does have "action" as an "IR Key" in probsummary

    I dont see an ir.probsummary or any "ir." files in c:\program files (x86)\HP\Service Manager 9.40\Server\data (i only see .unl files in this directory)

     

    what is going on?!

  • The IRQUEUE Process is like any other process in the sm.cfg file.  Look to see if you have:

    sm -que:ir

  • Verified Answer

    Jeff, try the following to see if the clears your problem with your "search".

    1. Close out of your service manager client. 

    2. Open up "Services" on your machine and stop the HP Service Manager service on your server.

    3. Navigate to the installation folder for your Service Manager server and edit the sm.ini file to add the line (without quotes): “ir_asynchronous:0”

    4. Start the HP Service Manager service on your server
    (delete all the existing ir.probsummary records in scirexpert) – this may not be necessary as the regenerate IR index may fix this

    5. Go to System Definition | Tables | Probsummary | click on “Regenerate IR Index

    6. After it finishes the index regeneration, restart your service manager client again.

    7. Lastly, try a text search with your keyword to see if the issue is fixed. 

    **I can include screenshots if needed but the directions should be straightforward.