issue to install hp ITSM deployment manager

Hi expert

i have an issue to run HP ITSM DM on windows server 2012 R2 X64 with tomcat/java 8

i got this error in my browser:

HTTP Status 500 - An exception occurred processing JSP page /index.jsp at line 21

type Exception report

message An exception occurred processing JSP page /index.jsp at line 21

description The server encountered an internal error that prevented it from fulfilling this request.


org.apache.jasper.JasperException: An exception occurred processing JSP page /index.jsp at line 21

18:         Injector inj = (Injector) pageContext.getServletContext().getAttribute(Injector.class.getName());
19:         UserSettingService userSettingService = inj.getInstance(UserSettingService.class);
20:         UserProvider currentUser = inj.getInstance(UserProvider.class);
21:         UserSetting userSetting = userSettingService.getByUser(currentUser.get().getId());
22:     %>
24:  <% if (userSetting != null && userSetting.isDebug()) {%>

root cause

note The full stack trace of the root cause is available in the Apache Tomcat/8.0.29 logs.

Apache Tomcat/8.0.29

any suggestion please


  • Verified Answer

    Hello Anou,

    hope you are doing fine,

    is your OS 64 bits or 32 bits?

    if is is 64 bits, could you please test on 32 bits environment? most of HPW toos are for 32 bits. Please let us know if the status 500 still appearing.

    If that doesn't work, please verify which java version is taking the system, running the java version on the command line.

  • Carlos, is ITSM DM still being developed? I have not seen any new releases and the Container technology would replace this .

    Anou, you might want to wait for an answer before using this tool? But should be fine to use in test/qa environment and it's great for fast setup and management of SM env.

  • Hi Carlos

    thank you for your response

    i use windows 2012 R2  x64,  tomcat 8.0.29  and java 8U65 64 bit also

    i tried to download HPDM version 3.1 but i didn't found it

    i was worked with old version in other project  and it worked

    thank you for your support