Map CI related Blob fields to an alias table

Hi experts,

I have just upgraded my SM 9.41 app version from 9.40 to 9.41 using Applications Patch Manager. After the update, there is a pop-up message regarding Blob fields.

 

I tried to fix the Blob fields following the guide, https://softwaresupport.hpe.com/km/KM01653844/logical_name_solution.pdf?lang=en&cc=us&hpappid=202392_SSO_PRO_HPE Step 4: Map CI related Blob/Clob fields to an alias table but was stuck on step 3 at the Preparation phase.

When I create a new affected.services field and save it, I get an error as below:

However, no error if I create a new assets field following the guide. 

Can anyone advice why is it so?

Thank you

Parents Reply Children
  • Hi Mike_Gross,

    Thanks for your reply. FYI, this is the error message I received once I update SM to 9.41 app version via APM. 

    Then follow the error message, I look into KM01653844 and follow the instructions on pg 25 Step 3. Create new alias tables for the dbdict records.

    As the guide is not specific enough, I follow the guide and create a new affected.services.new field and input the same value for (SQL Type, SQL Name, SQL Type) as affected.services field in the cm3r table. (If you see the guide, that's what the guide did for assets.new field in cm3r table for the example.

    Kindly advice. Thank you.

     

  • Verified Answer

    Without seeing your screenshots before you receive the error, it's difficult to say what you're doing wrong. I can share the steps I used to add the alias, and you can check them against what you're doing to see if they match. If not, you can try these steps in a development or test environment that has a full backup ready in case something goes wrong.

    1. Log in to SM as a SysAdmin user

    2. Tailoring > Database Dictionary

    3. File Name:cm3r

    4. Search

    5. Select cm3r from the list

    6. With the mouse cursor focused on the descriptor field, click New Field/Key

    7. In the pop-up window that's displayed, enter Name:affected.services.new (or any name of your choice) and select array from the Type drop down

    8. Click the Add Array button (the sign)

    9. In the next pop-up window, select Character from the Type drop down

    10. Click the Add Array button (the sign)

    RESULT: The new field should be added at the bottom of the dbdict

    11. Double click the "character" line of the newly added field

    12. Enter a SQL Name of AFFECTED_SERVICES

    13. Enter a SQL Type of VARCHAR(200)

    14. Enter a valid "a" table for the SQL Table field. In my system, I used a3.

    15. Ok

    16. Ok

    RESULT: SM should prompt with an Alter statement

    17. Confirm that the Alter statement looks correct, and choose SM Alters

    18. The field should be added without any errors assuming SM has write access to the database.

  • hi Mike_Gross,

    Thanks for your response. I will test it out and update the results later.

     

  • hi Mike_Gross,

    Thanks for your response again.

    I have tried it out and it is working now. (That's weird because previously I did the same but I get an error)

    Just an enquiry, to map the CI related Blob fields to an alias table following this guide, https://softwaresupport.hpe.com/km/KM01653844, the new field which we create the value can be any random values or we should follow the value of the field which is existing in the db?

    For example, the affected.services field in the cm3r table is as follows:

    Name - affected.services

    Type - array

    Level - 2

    Index - 102

    SQL Name - 

    SQL Type - 

    SQL Table - 

    Name - affected.services

    Type - character

    Level - 3

    Index - 1

    SQL Name - AFFECTED_SERVICES

    SQL Type - TEXT

    SQL Table - m2

    So for the new field which I create (affected.services.new) is it the value need to follow those as above?

    Also, if I did not map the CI related Blob fields to an alias table, will there be any impact to my environment? Attached is the error message screenshot I received after upgrade app verson to 9.41.0020

    Kindly advice.

    Thank you