Smart Email setup

Hi Everyone

I have looked at the help but it is very high level it seems or missing some fundamental info around how to configure outboud smart email. I inserted emailout parameters in the sm.ini as described in the help documentation but the sm.log reports it as an unrecognised command. See below for lines in .ini

sm -emailout -sleep:30
sm -emailout -keepmail
sm -emailout -smtphost:<mailserver here>
sm -emailout -smtpport:25
sm -emailout -mailFrom:<address here>

I also configured SmartEmail settings from System administration > Ongoing manintenance > Smart Email > settings

What am I missing?

thanks

Shane

  • Verified Answer

    In sm.ini, you must only put the parameters (ex, smtpport:25), without the sm -emailout. An example sm.ini could have the following:

    smtphost:1.2.3.4

    smtpport:587

    mailFrom:service.manager@domain.com

    smtpusername:service.manager

    smtppassword:password

     

    Make sure you have created an smtp user in your Exchange Server, as his credentials will be used from HPSM to send outbound emails.