Connect-It: Java Error on Launch

Hello, I am getting an error when launching connect-it 9.6.0.   Cannot Start Java - System Error 193, Failed to load JNI Library.  I have connect-it installed on my Service Manager App Server with JRE 1.8.0_60.  The references I found said that this may need to the 32-bit version, is that correct or is this a different issue?

 

Joe