Urgent: Cannot login to SM: Caught XML API exception: scxmlapi(5) - Invalid thread number

 

Hi, all

This is the urgent problem to be fixed as soon as possible. I have received an error message like below and become not be able to log into the Service manager at all neither from web nor windows client.

I found the post below which shows the similar problem. But I have no clue how to fix this probelm because I am not allowed to log in Service Manager at all.

Link

From sm.log

1416( 3948) 12/22/2015 17:21:58 RTE W Caught XML API exception: scxmlapi(5) - Invalid thread number
1416( 4000) 12/22/2015 17:21:58 JRTE W Send error response: A CXmlApiException was raised in native code : error 5 : scxmlapi(5) - Invalid thread number
3540( 2712) 12/22/2015 17:22:22 RAD E Cannot execute application named: menu.manager

  • This message seems to indicate that the menu.manager application is missing or corrupted.   I assume you have a test system where you can login, if so login to that system, go to the RAD editor and view application menu.manager from the drop down menu select "Export/Unload Application" fill in the file name then "Unload Appl".

    Next move that unload file to the RUN directory of your SM server, from the RUN directory issue this command

    sm file.load unloadFileName NULL NULL winnt

    If you are on Unix change 'winnt' to 'unix'

    If that does not work I would suggest opening a support case.

  • Thanks for your suggestion.

    I tried your suggestion but it didn't fix the problem yet.

  • I suspect your operator account's menu settings are flawed. Also, please tell which SM version you use and have you recently done upgrades, version changes etc. bigger operations. Or this "just happened" :)

    (I wrote this with a version SM 9.3x in my mind, without Process Designer installed. This requires a bit expert knowledge and if this rises more questions than answers, better to forget this approach,)

    Because you are not able to log into SM, check from database, where SM is hosted, if your user account's menu settings are fine. If you are not able to do that, please ask your DB admin to do it.

    They're located in a operator table (OPERATORM1 in SQL). Do a SQL search and look columns APPLICATION_NAME, NAMES and VALUES of your user account. If possible compare the values to some other user, that you know using same settings.

    For example in my case, values are:

    APPLICATION_NAME: menu.manager

    NAMES: name prompt string1

    VALUES: USER MENU menu.prompt.1 USER MENU

    If values are different or they are missing, use a simple SQL update operation to copy valid values from another operator's record to fix the issue.

    If the values are fine, I think the next step is to analyze has the menu item (for example USER MENU or one of its sub items) been somehow altered. Is it possible and to one of the menus you use have been altered recently?

  • Verified Answer

    Thanks for your reply. Finally, the problem has been solved.

    I write down what I did for someone who may face the similar situation.

    1. Unload object called 'Incidents', which was seemingly broken in the development environment and triggered the problem from the production environment. You can get the object from Tailoring -> Document Engine -> Object
    2. Apply the unloaded object to the development environment, replacing the broken object with the one working correctly.