my SM stop sending email notifecation for change managment

please help me as my SM is stop sending notifecation in email while creating new change managment.

 

 

  • Hi uops1,

    Have you checked the email service? I should check if the problem is working well. Did you check if the condition of notification does not changed? Have you upgraded the SM?

    Whether problem or email service are working, well could you tell me how you are sending this notification. Whether you are using notification or macro???

     

    Thanks in advanced.

  • hii dear,

    the email servivces is working fine and i did not touch the configuration. also, i did not do any upgrade or in environment.

    i am using notifecation as it was sending automatickely for any thing.

     

    please help

     

    regards,

     

  • Do a trace using RTM:3 and debugdbquery:999.  From the log, you should be able to tell if it passes through the notification engine.

  • Try to do telnet from sm server to exchange server, May be exchange team might change the ip address or blocked the port.

    One more thing check from command line type eventout. Find out how many mails are stuck!!

  • dear how i can trace using RTM:3 and debugdbquery:999   ??

    please explain ?

  • communication from SM to exchnage is fine.

     

    the exchnage reciveng email by also using connect IT

  • Hi Uops,

    1- Which HPSM version are you using?
    2- Only in Change Management HPSM is not sending notifications? or is it for everything?
    3- Are you using scsmtp for sending emails or Connect-it?
    4- Can you share the sm.ini file?
    5- you can add RTM:3 and debugdbquery:999 in the sm.ini & restart the sm services (if you can restart the sm services, but remove the email eventout so it won't be sent again)


    if you don't want to restart the sm services, what you can do is the following: 
    a- Navigate to the …/RUN folder (in command prompt)
    b- Start from command line : sm -httpPort:12345 -httpsPort:12346 -log:..\logs\debug.log -debugdbquery:999  -rtm:3 -debughttp:1 -debugnode:1
    c- Connect with a user using the port 12345 (from the tick client)
    d- Try to reproduce the issue, & check the log files.


    Best regards,

  • hii dear

     

    1- Which HPSM version are you using?  sm 9.30
    2- Only in Change Management HPSM is not sending notifications? or is it for everything? in change managment & sla notifecation.
    3- Are you using scsmtp for sending emails or Connect-it? I am using connect-it
    4- Can you share the sm.ini file? in atachment
    5- you can add RTM:3 and debugdbquery:999 in the sm.ini & restart the sm services (if you can restart the sm services, but remove the email eventout so it won't be sent again) sorry Dear I cannot restart any services during working hours also the clustering having issue in second server.


    if you don't want to restart the sm services, what you can do is the following: 
    a- Navigate to the …/RUN folder (in command prompt)
    b- Start from command line : sm -httpPort:12345 -httpsPort:12346 -log:..\logs\debug.log -debugdbquery:999  -rtm:3 -debughttp:1 -debugnode:1    what does this command do ?
    c- Connect with a user using the port 12345 (from the tick client)
    d- Try to reproduce the issue, & check the log files.

    sm.zip
  • Since the notification is working in the Interactions / Incidents / & Problems, it means that there is no problem with the notifications. 

    you have to check the conditions in the change management notifications so that it will be triggered.
    Have you done any modification on the change management notification module? 

  • i didnot change anything in sm itself as the notifecation for change managment & SLA are stop sending notifecation in email using connect-it