ITSM Deployment Manager support for SM 9.50

Is there is an imminent release of Deployment Manager that will support SM 9.50? All I can find is Version 3.1.1 and Version 3.1.2(Beta) both of which have support up to SM 9.41.