No HTML Editor in Service Manager Client

I am working with SM9.30 using the SM Client RTE Version: 9.30.281. If I try to create a new knowledge document via Knowledge Management >> Contribute Knowledge I do not have an HTML editor to create the content. The reference tab of the form is just empty. The behavior is the same for all available document types.

Any help/advice/idea will be very apreciated.

Thanks, Norbert

  • I believe you find a solution from this post:

    The problem is caused by a new browser version, which is now longer recognized by FCKEditor component. (FCKEditor is btw its real name, not my gibberish....)

  • Hi Kelalek2,

    Thanks for your quick response. Unfortunately the article does not solve my issue. I am using the Eclipse Client and changed the .ini file as mentioned in the article but the editor is still unavalable.

  • Make sure the version of Internet Explorer you have installed is compatible with your version of Service Manager.

  • There were two possible workarounds. Did you try both? For reference I've pasted both below.

    Workaround 1:

    Change value of registry entry "ServiceManager.exe" in the location below to 8888

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeaturControl\FEATURE_BROWSER_EMULATION

    Workaround 2:

    1. Modify <Installation Path>/eclipse.ini to add the configuration below to the end of the file

    2.Click <Installation Path>/eclipsec.exe to start SM Win Client.

  • I had the same issue ( on 9.40 )  but only on Windows 7 machines, the two workaround above worked for me.

  • I also faced a situation that the standard tricks didn't work, so I modded the FCKEditor's JavaScript files - and tried to skip the browser recognition.

    As a sidenote, I'm using Windows 7 and IE11. Confirmed that these changes work both in client versions SM 9.34 and SM 9.41.

    The two files you need to modify are:

    • fck_startup.js, path (for example) C:\Users\\ServiceManager\workspace\.metadata\.plugins\\htmlEditor\\src\resources\FCKeditor\editor\js\
    • fckeditor.js, path (for example) C:\Users\\ServiceManager\workspace\.metadata\.plugins\\htmlEditor\\src\resources\FCKeditor

    Please note, that the version number varies depending on what client version you use.


    Find a text


    Change it to (simply remove !)


    Save a file.


    Find a function "FCKeditor.prototype._IsCompatibleBrowser".

    Add a line

    return true;

    to the line 137 or so, before the text "// Internet Explorer". Save changes.


    Restart the client and the FCKEditor should be visible again.

  • What I found trying out your solution was that I have two representations of the fck_startup.js as well as of the fckeditor.js file.

    fck_startup.js is in: 

    C:\Program Files\HP\Service Manager 9.30\Client\plugins\\src\resources\FCKeditor\editor\js

    and in:

    C:\Program Files\HP\Service Manager 9.30\Client\plugins\\webtier\fckeditor\editor\js

    fckeditor.js is in:

    C:\Program Files\HP\Service Manager 9.30\Client\plugins\\src\resources\FCKeditor

    and in:

    C:\Program Files\HP\Service Manager 9.30\Client\plugins\\webtier\fckeditor

    I edited all of them as proposed in Kelalek2's post above without any change in behavior. The editor within my Windows Client is still missing.

    In a next step I installed the HP Service Manager Client to another workstation. I was logged in to the workstation with my own Windows credentials and started the HPSM client with the same credentials as on my maschine. The editor was visible and usable(!). To make sure that my OS and my OS profile are set up properly I did a brand new installationof my desktop. The editior of the HP Service Manager Client is unavailable right out of the box. Also, it keeps beeing unavailable after modifying the .js file as stated above.

    I am currently running out of ideas .....

  • Hi, Can you please share if your issue is resolved ? If yes then you can post the answer here, it ll help others too. If not then you can log a case with HP Software support or Professional Services for customization requests.
    HPE Software Support

Reply Children
  • Verified Answer

    Hi, the issue I've had is solved. The root cause was a wrong script used to install the Windows Client automatically. The script created an entry in the start menu as wel as an icon on the desktop that started the ServiceManager.exe directly. Thas was the reason why all changes .ini had not effect. Since the menu entries are pointing to the ServiceManager.cmd file, it picks up the .ini file and shows the web editor.

    Thanks to all of you for your support