After adding attachments using IE10, buttons on the web client stop working

We upgraded our web client from 9.32 to 9.35, deploying the new web client (like a brand new installation). Аfter the upgrade, we received complaints from users using the Web Client   IE 10: if users add new attachment, buttons on the interface stop working without any error in the SM log file and in the message console. If users click  for example "save" button or "cancel"...  nothing happens.  With IE11 and IE9 we don't have any problems, users are abler to add attachments. Compatibility is present in the matrix of the browser IE 10. How we can fix it?

  • Verified Answer

    Hi,

     

    Please try to delete Web Server and browser cache.

    If the issue is still present open a support case and trace the problem following the bellow steps:

     

    Web Client Trace
    ==========
    1) Configure the Web Tier:
    a) Locate the web.xml file in the Web Application Server installed applications directory.
    For Example: webapps\sc\WEB-INF\web.xml
    b) Open the file with a text editor
    c) Search for the parameter name honorUrlPort
    d) Ensure that the value for this parameter is set to true (The value should be directly below the parameter name)
    e) Save the changes and Exit
    f) Recycle the Web Application Server and Web Server for the changes to take effect (if necessary)

    2) Start a tracing port on the Service Manager Server
    a) Launch a dos prompt or Unix terminal equivalent
    b) Navigate to the Service Manager Server RUN directory
    c) Enter the following command: (The reference to 12345 can be changed to an available port if 12345 is already being used or unavailable)
    sm -httpPort:12345 -RTM:3 -debugdbquery:999 -sqldebug:1 -debughttp -log:webclient.log

    3) Launch the Web Client and connect to the correct port
    a) Open a web browser
    b) Enter the Web URL that is normally used to connect to Service Manager, for example:
    _localhost:8080/.../index.do
    c) append the following to the URL:
    ?serverPort=12345
    The result is the following URL:
    _localhost:8080/.../index.do

    4) Login and reproduce the issue.

    5) Logout

    6) Send the traces to Support, they will be located in the run directory under the name webclient.log and HTTP.log

    7) Terminate the tracing port started in step 2.

     

    BR,

    Alex

  • This is a known problem that is currently being researched by Support and R&D. In the interim you can use the following workaround: In the <application server (i.e. tomcat)>\webapps\<sm>\WEB-INF\classes\application-context.xml file there is a filter checking for Internet Explorer (IE) . It is checking with RegEx to see if the brower is IE. If it is IE to use a specific compatibility.

    <entry key='X-UA-Compatible"><value>IE=10</value></entry>

    Change this value from IE=10 to IE=9 or IE=11.
    Stop the webtier application server (i.e. Tomcat)
    Clear application server cache
    Start application server
    Tests have shown this solves the problem

  • Thanks,

    cleaning the tomcat cache solved the issue. I deleted all temporary files, and restarted the service.

     

    Maria

  • Very good. Keep the above workaround in your notes. I'm seeing this problem as being prevalent on a few systems, but not others. Glad clearing the cache solved the problem.

  • Not sure if you are using SRC as well. You will need to clear it's caches too. All caches should be cleared after an upgrade. Older versions in caches causes very weird results when still in use.