Attachments not adding on creating a Quote

The issue is that when I create a quote and add the attachment, the quote gets created but the attachment gets lost. I checked in the SYSATTACHMENTS table too but I cannot find any entry for that quote.

My client wants that the users should be able to add the attachments too while creating the quote.

Has anyone observed this behavior?

Parents
  • Hi Mayur,

     

    I am not familiar with SR but the issue you mentioned is due might be due to as per design of SM.

    If your quote unique id is not generated at the time of attaching the file then attachment would not be attached to record at all.Because it is mandatory to have record id to write entry to SYSATTACHMENTS table.So you need to have ID first by submitting the quote then add attachment and the save record .

     

     

    HTH,

  • Hi,

    Thanks for the response.

    I know that the record id is required to make an entry in the SYSATTACHMENTS table. But for the users, its like an extra step for them just to add the attachments. So they have to first create the quote, then add the attachments, save the quote and then move it to the next phase.

    Is there any workaround for this? This bevaior is not in any other module. I can create a change, incident etc with the attachments.

  • Hi,

     

    You can not avoid that step because SM is designed that way.And it is clearly mentioned in help server and also told by HP that it could not be possible to attach without record id.I do not any workaround for it and never found anybody to implement it as described by you.

    And regarding other module it is always need of record id to attach atleast till SM7.1x version,do not know if it is changed in 9.x version or not.If you are able to attach(till 7.1x) then record id must be there.For SD and IM module there is functionality(in environments records) to generate id before submit/creating of record so it is possible there but for change module it is not possible.

     

     

    regards,

Reply
  • Hi,

     

    You can not avoid that step because SM is designed that way.And it is clearly mentioned in help server and also told by HP that it could not be possible to attach without record id.I do not any workaround for it and never found anybody to implement it as described by you.

    And regarding other module it is always need of record id to attach atleast till SM7.1x version,do not know if it is changed in 9.x version or not.If you are able to attach(till 7.1x) then record id must be there.For SD and IM module there is functionality(in environments records) to generate id before submit/creating of record so it is possible there but for change module it is not possible.

     

     

    regards,

Children
No Data