Deployment Manager - Apache Tomcat installation failing with null path error

I am attempting to perform a first time Service Manager installation using the package created by the "HP Service Manager Installation" wizard.  The second step in the package is to install Tomcat.  This step is failing with error message...

"Cannot bind argument to parameter 'Path' because it is null."

I get this error in both DM v3.1 (Build20160122011026) and DM v3.1 (Build20160511014048).   I have tried performing the installation using both the default installer path value of "c:\" and a custom installer path value but the Apache Tomcat installation fails with the same error using both installer path values.

Has anyone else encountered this error condition?

  • Greetings Peter.

    We are doing research on our side regaridng this matter, we will provide a resolution for the same as soon as possible.

  • Hi ,

    Can you please let me know if you have stuck on the step where we need to install Tomact and then deploy DM war file or if you have stuck on any other step where tomcat installation is failing, let me know about it?

    if you have stuck on above step where we need to install tomcat and then deploy DM war file, let me know which version of tomcat you are using and which Java version you have and what is the OS version?

    Are you installing the tomcat manually?

    What I know Deployment manager can be instaled on Apache Tomcat 7 x 64 and Java 7 and JVM should be set between 512 MB and 1024 MB.

    Thanks & Regards

    Animesh

  • Hi

    Adding to my last update if you are using DM to deploy tomcat to setup webtier for SM and it is failing, can you please sent me the log info found in:
    <CATALINA_HOME>\logs

    And the task you created for this ( Screen shot related to it) so I can check that.

    Thanks & Regards

    Animesh

  • Thanks for the update.  I suspect you have my case but if you do not my HPE support case is 5315380522 and it is being worked by Jose Arias.

  • Hi Animesh --

    I have installed DM successfully - no issues with that. The step that is failing for me is within the DM package to perform a Service Manager installation. The first "task" in the package is to install Java and this works. The second "task" in the package is to install Apache Topcat and this is the step that is failing for me. The Tomcat instance that is running the DM application is 8.0.28 with JRE 8u111. The min/max JRE heap is set to 512MB for both at this time.

    Thanks!

    Peter

  • Verified Answer

    Hi Peter,

    Thanks for the reply.

    As you have already opened the support case , we can track the issue there.

    Please let me know if you still need my help.

    Regards

    Animesh

  • Though it still has some rough spots, all in all, DM is best thing since sliced bread.

    I used DM to install Apache.  No problems at all..

    I am using Version3.1 Build20160511014048.  Perhaps you should download this version (it seems to be a bit later than yours).

     

    Respectfully

    Stacy Whetzell