Attach a file in the add action while opening Incidents

Hi,

We want to open Incidents (IM) with attached files. We want to attach files in the add action.
We have added an attachment section in the IM.open.incident form.

When you open a new Incident with an attached file (see screen capture attached), the IM is opened but attachment is not saved.
If you attach a file when the IM is opened, in the update action, attachments are saved properly.

We have detected that, in the open action, the form doesn't show the IM number (it's empty).

DO you know how we can open IM with attached files?

Thanks!

Our software versions are the following:

BACKEND CONFIGURATION
SM Server RTE version: 9.34.2003-P2.
SM Application version: 9.34.2003-P2.
Server OS version: OS version Windows Server 2008 R2 Standard SP1 Intel 2,90 GHZ with 4 CPUs. 8Gb RAM.
Java version: 1.7.0_75 64-bit.
Oracle database version:  11.2.0.3.15 in Case Sensitive Mode


FRONTEND CONFIGURATION
OS version Windows Server 2008 R2 Standard SP1 Intel 2,90 GHZ with 4 CPUs. 8Gb RAM.
Tomcat 7.0.55
Apache 2.2
HP Service Manager Web-tier 9.34.2003-P2.
JRE 1.7.0_75 64-bit.
Thank you.

  • Check the Incident Management environment record.

    You're correct in that it has to do with the IM number.  The SYSATTACHMENTS table and processes use the unique key of the record it belongs to in order to link the Attachment with its record.  When there's no IM number, the system doesn't know what record the attachment belongs to, so it actually probably saves (check the SYSATTACHMENTS table), but doesn't link to the ticket correctly.

    In the Incident Management environment record (Menu Navigation -> System Administration -> Ongoing Maintenance -> Environment Records -> Incident Management Environment) there's an option 'Delay Assigning Incident Number'.  If that box is checked, then it won't grab the IM number until the record is saving.  With it unchecked, the system should populate the IM number as soon as you select to Open New Incident, which should solve your attachment issue.

    Since it is an Environment setting, make sure it is unselected, save the record, then log out of HPSM and log back in to set it for your environment.