Testing Upgrade from SM 9.34 P5 (non-PD) to 9.41 P5 Classic

I am running SM 9.34 P5 (non-PD). I am testing an upgrade to 9.41 P5 Classic. After upgrading the binaries and platform components I am receiving the following error in the sm.log.  The SM 9.41 P5 release notes direct you to leave that parameter in the sm.ini, if running 9.3x applications.  Any ideas why I am receiving this error?

 

RTE W Option "KMSearchEngineClass:com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch" not recognized

  • Hi SCSM123

    hope you are doing fine.

    Remove the following line from all sm.ini files (LB APPs):
    KMSearchEngineClass:com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch

    This parameter is not relevant anymore in SM9.41 RTE. See Service Manager 9.41 release notes:

    8. If your sm.ini file already contains the following line, remove it.

    KMSearchEngineClass:com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch

    Note:
    o  Skip this step if you are running Service Manager 9.3x applications.
    o  This parameter is no longer needed for the Service Manager 9.41 Solr Search Engine.
    If it is present in the sm.ini file, a warning message will occur in the Service Manager server log (sm.log).

  • The notes say "Skip this step if you are running Service Manager 9.3x applications." 

    I am running 9.41RTE with 9.34 applications, so I was thinking that I still needed it. 

    Am I wrong?

  • Hi,

    then you have to keep it,

    please try below steps,

    1. stop solr server

    2. edit file KMCores\solr.xml and delete line <core name="Problem_Library" instanceDir="Problem_Library\"/>

    3. delete folder KMCores\Problem_Library

    4. start solr server

    5. restart SM server

    6. login SM and Empty Search Server Name of your Problem_Library settings and save.

    7. Set Search Server Name with correct solr server name and save.

    8. Full reindex Problem_Library

     

    If doesn't work, please try this:

    KM uses it's own tomcat. So if you search the search engine folder, you will find a tomcat folder within, delete the contents of the work folder. This trick worked for me.

  • Hi Carlos,

    I tried both of your suggestions, but neither worked.  I am still receiving the following error.  Any other ideas?

    RTE W Option "KMSearchEngineClass:com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch" not recognized