(SP/Propel) Support Tip: What value to set in SM Supplier for LWSSO domain/LWSSO init string field?

What value to set in LWSSO domain and LWSSO init string field while configuring Supplier in propel for Service Manager?

Environment

Propel 2.20 P1

SM 9.4X

While configuring Supplier in propel for Service Manager, we now need to set two mandatory field

1 LWSSO domain

2 LWSSO init string

If LWSSO domain field and LWSSO init string is not set in supplier, we get the below message while configuring the SM supplier

 p1.png

Also the configuration check tab of supplier will shows status as Failed for LWSSOp2.png

We can get the value for LWSSO domain field and LWSSO init string field from the file lwssofmconf which is located on that path \HP\Service Manager 9.40\Server\RUN on your SM system and then set these values in supplier for service manager in propel.

In lwssofmconf file

1 The <domain>XXXXX</domain> value which exist in file lwssofmconf is mapped to LWSSO domain field in supplier for service manager in propel.

2 The initString value which exist in file lwssofmconf is mapped to LWSSO init string field in supplier for service manager in propel 

For example:  if your lwssofmconf file is like below

<?xml version="1.0" encoding="UTF-8"?>

<lwsso-config xmlns="http://www.hp.com/astsecurity/idmenablmentfw/lwsso/2.0">

            <enableLWSSO enableLWSSOFramework="true"

                        enableCookieCreation="true" cookieCreationType="LWSSO" />

            <web-service>

                        <inbound>

                                    <restURLs>

                                                <url>.*7/ws.*</url>

                                                <url>.*sc62server/ws.*</url>

                                                <url>.*/ui.*</url>

                                                <url>.*SM/9/rest.*</url>

                                    </restURLs>

                                    <service service-type="rest" >

                                                <in-lwsso>

                                                            <lwssoValidation>

                                                            <domain>propel220.com</domain>

                                                                        <crypto cipherType="symmetricBlockCipher" engineName="AES"

                                                                                    paddingModeName="CBC" keySize="256" encodingMode="Base64Url"

                                                                                    initString="smpropel"></crypto>

                                                            </lwssoValidation>

                                                </in-lwsso>

                                    </service>

                        </inbound>

                        <outbound/>

            </web-service>

</lwsso-config>

Then while configuring Supplier in propel for Service Manager you will set

LWSSO domain propel220.com

2 LWSSO init string smpropel

Save the configuration

Now the configuration check tab will show no error related to LWSSO

 p3.png

Tags: