Knowledge Management: How to get published documents to be added to a knowledgebase

Hello,

I'm pretty new to the KM area of SM, I'm having issues getting published documents to be added to a knowledgebase. I dont see anywhere to select which documents go into what knowledgebase. I've published multiple documents both internal and external and none of them are able to be searched in the knowledgebase search. 

 

  • The knowledge documents need to be indexe by the search engine. If you're not seeing these documents in the hitlist then here are a few things to check:

    1. Has a full index been run on the Knowledge_Library? To confirm:
      • Go to Knowledge Management > Knowledgebases
      • Access Knowledge_Library
      • What is the status? If it says Offline then run a Full Index so the collection is created in the search engine
    2. If the status in step 1 is Online and you see a value in the Docs field then perhaps KMUpdate background process is not running. Check to see if it's active in System Status. If it is then it's possible that the KMUpdate schedule record itself is in an error state. To confirm access the KMUpdate schedule record and look at the status field. It should say 'rescheduled'

    That's a few things to look. There are others, but I could go on. It would be best if you can tell me what you see regarding what I've already listed. 

    Lastly, what version is this? If SM 9.41 or 9.5x are you using Smart Analytics?

  • Thank you for your reply, 

    I'm on SM 9.33.

    When I go check the knowledge_library it says offline and when I click full reindex I get an message that say "Search engine or service manager settings incorrect or not found! Please 1) configure the Knowledge Management Environment Settings, 2) go to the KMUpdate schedule record, set Status resceduled and Class KMUpdate, and save, and 3) click Knowledge Management  > Manage Updates and click start."

    I've attached pictures of my Event Scheduler and kmupdateinfo. I'm not sure what is being asked in 1), but 2) looks okay, and nothing happens when I start the KMUpdate.

  • Do you have the search engine installed? It's a separate application and not "inside" Service Manager.

  • Would that be the KM search Server? Cause that says I dont have any added. How do I go about adding it?

  • It's on the 9.30 Installation CD - the one you used to install Service Manager 9.30 before patching it to 9.33 - in the Knowledge Management directory.  The installer will install the SOLR search engine into a seperate directory. Following that you configure Service Manager to connect to SOLR via Knowledge Management > Configure Search Servers. When that is complete you can run a full index on all of the Knowledge libraries. From that point on records will be indexed and available in search results.