IR Search no result return

I just activate IR on a new system.

#ir_disable:1
ir_asynchronous:1
ir_max_shared:80000000
ir_timelimit:50
ir_autostop:1
ir_max_relevant_answers:500
ir_boost_same_sequence:1
ir_trace:801

Reboot SM.

I used sm -util to regen IR "reg" on request (SM9.41) since it's a small file and in the test environment where are only 200 records.

OOB have 3 fields in the IR brief.description, description and update.action. we use the same IR.

I did some search with sm -util (open file request, qbe: brown) or directly in the SearchConfig format and the result always return nothing.

I also do the regen directly in dbdict for this file since it's only 200 records. Seem to regen somethings but no big result.

The trace look like:

8520( 8464) 05/20/2016 20:52:09 RTE D _gainControl: IR Query against file ir.request - 0/0
8520( 8464) 05/20/2016 20:52:10 RTE D IR: Just opened file scirexpert:ir.request with value FFFFFFFF
8520( 8464) 05/20/2016 20:52:10 RTE W WARNING: lock [3]IR Expert held for 500 milliseconds by routine ..\..\src\ir.cpp line 953
8520( 8464) 05/20/2016 20:52:10 RTE D IR: Data for file scirexpert:ir.request loaded using 0xFFFFFFFF
8520( 8464) 05/20/2016 20:52:10 RTE D ir_query_init() - Query: String to be tokenized: CS001
8520( 8464) 05/20/2016 20:52:10 RTE D ir_query_init() - Query: Token returned by token_next: cs001
8520( 8464) 05/20/2016 20:52:10 RTE D SearchTerm: Looking up 'cs001' in techterms dictionary
8520( 8464) 05/20/2016 20:52:10 RTE D SearchTerm: rc=0 - term 'cs001' not found in dictionary
8520( 8464) 05/20/2016 20:52:10 RTE D Query data: CS001
8520( 8464) 05/20/2016 20:52:10 RTE D Dump of Query
8520( 8464) 05/20/2016 20:52:10 RTE D 0x0CB59140: 43533030 31 [CS001 ]
8520( 8464) 05/20/2016 20:52:10 RTE D Querying token: cs001
8520( 8464) 05/20/2016 20:52:10 RTE D Dump of Query Token
8520( 8464) 05/20/2016 20:52:10 RTE D 0x0CF0EF50: 63733030 31 [cs001 ]
8520( 8464) 05/20/2016 20:52:10 RTE D Term cs001 not found
8520( 8464) 05/20/2016 20:52:10 RTE D IR: It took 297 milliseconds to read the terms
8520( 8464) 05/20/2016 20:52:10 RTE D Query with 0 terms found 0 documents
8520( 8464) 05/20/2016 20:52:10 RTE D ...which spread to 0 other terms resulting in 0 documents
8520( 8464) 05/20/2016 20:52:10 RTE D _giveupControl: file ir.request - 0/0

or

8520( 8464) 05/20/2016 21:26:33 RTE D ir_query_init() - Query: String to be tokenized: brown
8520( 8464) 05/20/2016 21:26:33 RTE D ir_query_init() - Query: Token returned by token_next: brown
8520( 8464) 05/20/2016 21:26:33 RTE D SearchTerm: Looking up 'brown' in techterms dictionary
8520( 8464) 05/20/2016 21:26:33 RTE D SearchTerm: rc=0 - term 'brown' not found in dictionary
8520( 8464) 05/20/2016 21:26:33 RTE D Query data: brown
8520( 8464) 05/20/2016 21:26:33 RTE D Dump of Query
8520( 8464) 05/20/2016 21:26:33 RTE D 0x0F5C1560: 62726F77 6E [brown ]
8520( 8464) 05/20/2016 21:26:33 RTE D Querying token: brown
8520( 8464) 05/20/2016 21:26:33 RTE D Dump of Query Token
8520( 8464) 05/20/2016 21:26:33 RTE D 0x0762A8B0: 62726F77 6E [brown ]
8520( 8464) 05/20/2016 21:26:33 RTE D Term brown not found
8520( 8464) 05/20/2016 21:26:33 RTE D IR: It took 0 milliseconds to read the terms
8520( 8464) 05/20/2016 21:26:33 RTE D Query with 0 terms found 0 documents
8520( 8464) 05/20/2016 21:26:33 RTE D ...which spread to 0 other terms resulting in 0 documents
8520( 8464) 05/20/2016 21:26:33 RTE D _giveupControl: file ir.request - 0/0

irfields are fine.

scirexpert have few ir.request records (13)..all seem empty but perhaps I just don't have good visual on that in SM Client.

Any idea how I can fix that?

 

Thank you,

Tags: