Service catalog not opening request



Although we have a mature request process and use Request Management in Service Manager, we are just now looking into using Service Catalog as the interface to open requests.  So far we haven't been able to get it to work.


We created a couple of simple categories, with one as the parent category and the other as the subcategory, then created a Service Catalog Item with the connector "Open New Request".  We are able to select the item, add it to the cart, and submit it.  This successfully opens an interaction, but the interaction sits in Open-Idle status and doesn't seem to attempt to open a request.  As far as I know, I've removed all requirements for approval, so this should not be stopping it.  Am I correct in assuming that if there are no approvals required then the ocmq record should open immediately after the final Submit of the Service Catalog request?


I've done a debug trace but being completely unfamiliar with what is suppose to happen in the background, I'm having a hard time determining what within the trace information might be significant.


Does anyone have any ideas about what might be causing our problem, or suggestions on where we might start looking.  I'm not familiar with all the data, or configuration files that might be significant to the process so any help or suggestions would be greatly appreciated.




Parents Reply Children
  • Hi Gaurav,


    Thanks very much for the response.


    As far as I can tell, the linker is working fine.  When I submit my Service Catalog request, a Service Catalog Fulfillment schedule record is created (calls the application) and the linker processes it, but the only thing I notice after the schedule record has been processed is that the status of the Catalog Item changes from Requested to submitted.  Still no request gets created.  Do you think this change of status is significant?



  • Hi,


    What connector for opening Request are you using?


    Have you customized that connector by writing some Javascript or expressions?


    Try using OOB connector.





  • Hi,


    Our first attempts were with the OOB connector.  We then tried modifying or removing some of the expressions in the connector, but still no request was open.  I think one of our problems is that we have a tailored Request Management module and this could be the source of our problem.  Also, it's difficult to isolate the significant activities in a trace log since it is a schedule record processed by the linker that seems to be responsible for initiating the open of the request, and since we do make it to the point, starting a separate listener for debugging has not been much help.  I think I will need to enable debugging on the main listener in the sm.cfg and wade through all the unrelated stuff to try and find the problem.



  • Hi,


    I even faced this issue when I wrote some Javascripts in the connector's process record to modify the parent interaction and quote while using "Open New Request" connector.


    Enabling trace on a servlet and checking would be a good option.


    Hope you find the rootcause and do keep us posted.  :-)



  • Verified Answer

    Hi Gaurav,


    We have resolved our issue.I didn't end up enabling a trace, but after additional investigation and trial and error I determined that the only things causing the problem were our ocmq formatctrl and our custom form's formatctrl.  When I moved the OOB ocmq formatctrl over to my tailored environment and applied an OOB formatctrl to my custom form, our Requests opened successfully.  I gradually started adding our custom stuff back into the OOB formatctrls until I found the elements that caused the request not to open.  In both formatctrls I had a Query set to Required and in one I had a post.fc Subroutine.  As soon as I removed the Required expression on the Queries and the Subroutine from the formatctrls the Service Catalog submission properly opened my Request.  Now I will just have to see if we still need these elements and figure out a way to add them back in that will not cause a failure.


    Thanks again for your help.



  • Dear Audrey,


    Even I face a similar issue as you had earlier.


    Could you please tell me what is the custom form's referring to?


    In the environment here even I haev all custom forms for SD and OCMQ.


    Kindly advise.