RTE Errors in sm.log file

Dear All,

we are getting lot of below error in sm.log file, not sure what could be the issue,

kindle let me know how to resolve the issue, is there any issue with database side, do i need to contact db team to resolve this errors, kindly help me on this.

We are using HPSM 9.40 without PD and Oracle db on linux machine.

27494( 28174) 01/13/2016 01:13:54 RTE E sqociTOD(): SQL type = 5 (STRING); data = 1007-10-28 03:30:53

27494( 28174) 01/13/2016 01:13:54 RTE E Unable to parse date for column EXPIRATION (scheduler,select.class)

27494( 28174) 01/13/2016 01:14:54 RTE E date format ' 1000-01-06 10:07:17' unrecognized in sqlda (scheduler,select.class)

27494( 28174) 01/13/2016 01:14:54 RTE E sqociTOD(): SQL type = 5 (STRING); data = 1000-01-06 10:07:17

27494( 28174) 01/13/2016 01:14:54 RTE E Unable to parse date for column EXPIRATION (scheduler,select.class)

27494( 28174) 01/13/2016 01:14:54 RTE E date format ' 1000-01-13 20:14:34' unrecognized in sqlda (scheduler,select.class)

 

Thanks,

Jagan

 

  • If this error suddenly appeared in the log I suspect that your Oracle is configured with TAF.   When SM connects to Oracle it sets the DATE_FORAMT for the connection.  This tells Oracle how SM wants to see the date, SYYYY-MM-DD HH24:MI:SS 

    With TAF, SM may silently loose the connection to Oracle and Oracle via TAF establishes a new connection but without the DATE_FORMAT that SM expects.

    Your sm.log would contain a message at startup if it detects that TAF is configured.

    ServiceManager does not support Oracle TAF. Please remove TAF configuration and restart ServiceManager to avoid running into outages.

    Steve Hirschfeld

    HPE Support.

     

     

  • Dear Steve,

    Thanks for your feedback, we have checked with our DBA team and they informed that the Oracle is not configured with TAF,

    Kindly let me know how to overcome this issue.\

    Thanks,

    Jagan

  • Hi, Jagan


    Somethings you can check,


    1. Upgrade both Oracle Server and Client to 11.2.0.3.0 or above


    2. Dedicated mode is enabled


    3. Check sm.log if it included the error message below,
    RTE E ServiceManager does not support Oracle TAF. Please remove TAF configuration and restart ServiceManager to avoid running into outages

    if it does include, that means Oracle TAF or failover is enable, please disable and try.


    Thanks


    Desmond