(SM) Support Tip: How to Improve search accuracy for Japanese language using in IDOL server .

Some customer is facing issue that the search accuracy for JP in IDOL server is not good enough for customer .

 So here is the steps about how to improve it.

1.Edit Smart Anaytics server IDOL C:\Program Files (x86)\HPE\Service Manager 9.51\SmartAnalytics\IDOL\ IDOLServer.cfg

<before change >

[japanese] Encodings=UTF8:japaneseUTF8 Stoplist=japanese.dat SentenceBreaking=japanesebreaking SentenceBreakingOptions=kana,oldnew,hyphen,dbcs,numbers Stemming=true

<after change>

[japanese] Encodings=UTF8:japaneseUTF8 Stoplist=japanese.dat NGram=2 NGramOrientalOnly=True Stemming=True

2.Restart Smart Anaytics Smart Anaytics server  

1) C:\Program Files (x86)\HPE\Service Manager 9.50\SmartAnalytics\scripts\stop.bat 2) C:\Program Files (x86)\HPE\Service Manager 9.50\SmartAnalytics\scripts\start.bat

3.Disable all the Chinese setting in IDOL like below :

\SmartAnalytics\IDOL\IDOLServer.cfg \SmartAnalytics\Content1\Content1.cfg \SmartAnalytics\Content2\Content1.cfg \SmartAnalytics\Content3\Content1.cfg

4. Set DefaultLanguageType to be japaneseUTF8 in configuration files.

Old: DefaultLanguageType=englishUTF8

New: DefaultLanguageType=japaneseUTF8 And restore all the components.

5.Do reindex on SM Client

1) System Administrator > Ongoing maintenance > Smart Analytics > Smart Search 

2) Knowledge_Library 

3) Full Reindex 

thanks


 
 
 

Tags: