Default access to to Index login to be disabled


Few of the End users in our organisation, who are supposed to get only access to HP SM ESS web client login by default are also able to get access to HP SM index login. .

i.e., we have two domain id users whose id is "ithelpdesk" and another is "hardware" , as per HP SM environment with LDAP enabled, all domain users get a access to ESS login by default, so here, both above mentioned id's are able to access ESS as well INDEX login.

Kindly help in understanding the arrangment here.

we want to ensure all the users must be having access to ESS login only by default.

Thanks and Regards
Hemant Vaswani


  • Check for a Template user *SYSDEFAULTS.  This is what the base operator record is created from.  Then check on the Self Service tab if the Self Service Access Only checkbox is checked. 

  • Hi HermantVaswani,

    You can edit index.html and set default URL to and unless the users manually set to it will always show, except if you have TSO or SSO and that fails they will be probably redirected to

    I'm trying to figure out if there is a way to totally disable it but you might be able to do it restricting it from tomcat itself.


  • There is an option in the web.xml to force ESS Mode. This sets that webtier instance as an ESS-only instance. (It does not actually "enable ESS" and should normally be set to false, it locks down that instance of web tier to ESS only).  If use this approach, however. you would need to configure another web tier for 

          ESS users would override this with URL param.
          But the application could be set to always operate in ESS mode if this
          were set to true. If so the user will not need to have that parameter set.
          When it is true the server is notifed so that the correct applications are initialized.

    I was at a customer where this was enabled by mistake and it forces ESS access. (Oddly, some users got in with and saw their todo list, but if they tried to edit records it then reverted to ESS screens). I haven't worked with it since 9.30.