Layer2 Topology VLAN-based by SNMP timing out

Using UCMB 10.11 CUP2 CP 14.03.230

 

I have enabled the following discovery jobs with success:

 

Range IPs by ICMP

Host Connection by SNMP

Host Networking by SNMP

VLANs by SNMP

VLAN ports by SNMP

 

But when I run the job "Layer2 Topology VLAN-based by SNMP", it indicates several thousand triggered CIs, but each one times out.  I disable the job after about 45 minutes since nothing is working.

 

All of our switches are Cisco Catalyst with VLANs.  I've tried to enable the job "Layer2 Topology Bridge-based by SNMP", but it never shows any triggered CIs.  And since we use VLANs, I suspect that it shouldn't run.

 

Using an SNMP query tool, I've verified that I can query my Cisco switches using the special community string format <COMMUNITY>@<VLAN NUMBER>.  I believe this is what the disocvery job should be doing as this is mentioned in the Discovery and Integration Content Guide.

 

Any ideas on what I am missing which causes the "Layer2 Topology VLAN-based by SNMP" job to timeout?

 

Thanks.