Inventory Scanner Trobuleshooting

UCMDB 10.32

CP 26

Hi 

I recently installed the CP 26 on my environment and after few days while i am checking the host. The count suddenly decreases. Also when i found out that many hosts merged into one now i can check that one host is having around more than 900 ipaddress. I checked for that host only one ip is there for it.

I checked the logs in that cmdb.recoincilation is frequetly merging the CIs through the Inventory Scanner job.

Also the other jobs are in pending state as they are in loop.I cheked that no job is executing from the server side it reaches to the probe and probe sent the result to the server but no job is going to complete.

The thing i changed after the CP 26 installed is that i changed the XML Enricher of one probe  from 34545 to 34546. NOthing else.

Somebody can help me in this.

 

Parents
  • Hi,

    May be the problem came with CP26.

    Now I see that CP27 is out.

    have you tried the new CP27?

    Regards,

    Damir

  • This is a classic symptom of a false supernode. Aa node which due to improper merging ends up with hundreds of IPs and other wrong related CIs.
    It's a long story and it can be fixed with a deeper analysis.
    If you have UCMDB 10.33 at least then you can go for CP27.

  • HI we are using UCMDB 11.

    UCMDB 11 came with CP26 OOB.

    We will try to install CP27 and see if problem will be fixed.

    p.s. Inventory scanning throug zone jobs is working fine but this whole problem start when we run Invenrory by Scanner.

    So I'm hopping that the problem lies on the scanner side not in data.

  • Hi,

     

    We have UCMDB 2018.05 and we do face the similar issue, we observe around 780 Servers majorily Linux Sevrers are getting merged in to single CI with 1800 IPs.

    We also see that until we run the Scanner Job and we run only Host Connection by Shell job it is fine. Once we run the Inventory Discovery by Scanner Job we see this issue appearing and merging the CIs.

    Did you get any Solution for this or its another bug in the Product?

    Regards

    Ashok

  • Hi Ashok, I haven't got any solution for this till now and i suspect if you go and check for the history also it will not pop up. What i did is that i deleted the problematic CI and stop the scanner job until every other job is not completed. If you find any solution for this please reply on this. Regards Ayush
Reply
  • Hi Ashok, I haven't got any solution for this till now and i suspect if you go and check for the history also it will not pop up. What i did is that i deleted the problematic CI and stop the scanner job until every other job is not completed. If you find any solution for this please reply on this. Regards Ayush
Children