Problem with UCMDB to ServiceNow push adapter

I have tried to set up an integration of Windows CI using the out-of-the-box Service-Now Push adapter.


ServiceNow is accessed via https over proxy and I have checked that I have access from the data flow probe server I am using for the integration.


The additional classpath is added according to instructions. My query returns 258 CI´s and my mapping file have the same name as the query according to the instructions and I have also tried with the sample query/mapping.


A test run gives the error message pasted below.



<2014-08-22 13:33:55,433> [ERROR] [AdHoc:AD_HOC_TASK_PATTERN_ID-81-1408707266802] ( - Failed execute ad hoc script: Traceback (most recent call last):
  File "<string>", line 2, in <module>
  File "pushToServiceNow", line 736, in DiscoveryMain
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

	at sun.reflect.NativeConstructorAccessorImpl.newInstance(

	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(

	at java.lang.reflect.Constructor.newInstance(

	at org.python.core.PyReflectedConstructor.constructProxy(

java.lang.Exception: java.lang.Exception: [DiscoveryMain] [processCIs] [processCIs:add] Error connecting to Service-Now while processing CIT <cmdb_ci_win_server>

<2014-08-22 13:33:55,434> [ERROR] [AdHoc:AD_HOC_TASK_PATTERN_ID-81-1408707266802] ( - Failed executing probe request [com.hp.ucmdb.discovery.probe.request.GenericPushProbeRequest] for integration [ServiceNow push test]


Does anybody have an idea what could be wrong?


Kind regards,


Parents Reply Children