IP Range by ICMP failing after upgrade to 10.01

I am seeing the following error in my logs when running my ping sweep.  Is there something I can do to resolve this?

 

Can't execute BATCH prepared statement [INSERT INTO HDM_140410IP_ADDRESS_1( ID, CMDB_ID, A_DATA_ALLOW_AUTO_DISCOVERY,A_IP_ISBROADCAST,A_AUTHORITATIVE_DNS_NAME,A_CITY,A_USER_LABEL,A_IP_ISDHCP,A_ROOT_ENABLEAGEING,A_CALCULATED_ID,A_CREATE_TIME,A_IP_PROBENAME,A_TENANTOWNER,A_GLOBAL_ID,A_IP_NETCLASS,A_ROUTING_DOMAIN,A_IP_NETADDR,A_IP_NETMASK,A_ROOT_ICONPROPERTIES,A_ACK_ID,A_ROOT_CONTAINER,A_ARP_MAC,A_DATA_EXTERNALID,A_DATA_SOURCE,A_COUNTRY,A_DATA_ORIGIN,A_IP_NETTYPE,A_DESCRIPTION,A_DATA_NOTE,A_IP_ADDRESS,A_ACK_CLEARED_TIME,A_IP_ISMANAGED,A_LANGUAGE,A_DIGEST,A_CREDENTIALS_ID,A_IS_SAVE_PERSISTENCY,A_STATE,A_IP_DHCPDOMAINNAME,A_CODEPAGE,A_IP_ADDRESS_TYPE,A_ROOT_SYSTEM,A_TRACK_CHANGES,A_DISPLAY_LABEL,A_NAME,A_IP_ADDRESS_PROPERTY,A_IP_ADDRESS_VALUE,A_ISVIRTUAL,A_DOCUMENT_LIST,A_IP_LEASE_TIME,START_TIME, CHANGER_DATASTORE,CHANGER_INFO,CHANGE_TYPE,LIST_UPDATED_ATTRS) VALUES (?, ?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,'UPDATE_OBJECT_PART',?)], failed prior to DB execution due to exception: com.mercury.jdbc.sqlserverbase.ddc: [mercury][SQLServer JDBC Driver][SQLServer]Invalid object name 'HDM_140410IP_ADDRESS_1'.

Parents
  • Hi Adam,

     

    The error you are seeing is caused due to a change in class model (addition of attribute and change of different attribute qualifier to lowercase) a change in the data and history tables itself was initiated before the actual tables were changed.
     
    Please open a Support ticket and provide us with the logs for further investigation and to ensure a proper workaround is provided to you.
     
    Thank you,
    Ana Acosta-Diaz
  • I've opened a support case and they instructed me to redo the upgrade and install the latest CUP on 9.05 before I upgraded.  I did what they asked and now the Range IP job completes.  The Host Resources by WMI is now failing.  I am seeing a similar error in the log:

     

    Can't execute BATCH prepared statement [INSERT INTO HDM_140510INSTALL_1069639091 (ID, CMDB_ID, A_CITY,A_SOFTWARE_TYPE,A_USAGE_HOURS_LAST_QUARTER,A_CREATE_TIME,A_INFOCUS_USAGE_H_425663301,A_TENANTOWNER,A_RECOGNITION_LEVEL,A_INFOCUS_USAGE_D_1065560163,A_ROOT_CONTAINER,A_DATA_EXTERNALID,A_DATA_ORIGIN,A_DESCRIPTION,A_DISCOVERED_VENDOR,A_NUMBER_OF_POINTS,A_SAI_VERSION_ID,A_ACK_CLEARED_TIME,A_LANGUAGE,A_SERIAL_NUMBER,A_UTILIZATION_UPDATE_DATE,A_DIGEST,A_INFOCUS_USAGE_D_765962743,A_USAGE_DAYS_LAST_QUARTER,A_CODEPAGE,A_USAGE_DAYS_LAST_MONTH,A_IS_SUITE_COMPONENT,A_TRACK_CHANGES,A_DISPLAY_LABEL,A_NAME,A_INFOCUS_USAGE_D_856339942,A_FILE_SYSTEM_PATH,A_ISVIRTUAL,A_INFOCUS_USAGE_H_1966644303,A_LAST_USED_DATE,A_SOFTWARE_PRODUCTCODE,A_DATA_ALLOW_AUTO_DISCOVERY,A_USER_LABEL,A_BUILD_NUMBER,A_SOFTWARE_DATA,A_USAGE_HOURS_LAST_MONTH,A_SOFTWARE_LICENSE_TYPE,A_DML_PRODUCT_NAME,A_VERSION,A_ROOT_ENABLEAGEING,A_CALCULATED_ID,A_USAGE_HOURS_LAS_1727212118,A_GLOBAL_ID,A_ROOT_ICONPROPERTIES,A_ACK_ID,A_USAGE_DAYS_LAST_YEAR,A_COUNTRY,A_DATA_SOURCE,A_DATA_NOTE,A_VENDOR,A_INFOCUS_USAGE_H_1726355598,A_CREDENTIALS_ID,A_INFOCUS_USAGE_H_179885162,A_IS_SAVE_PERSISTENCY,A_STATE,A_SOFTWARE_LANGUAGE,A_USAGE_HOURS_LAST_YEAR,A_ROOT_SYSTEM,A_INFOCUS_USAGE_PERCENT,A_RELEASE,A_SOFTWARE_PRODUCTID,A_DOCUMENT_LIST,A_SOFTWARE_CATEGORY_ID,A_USAGE_PERCENT,START_TIME, CHANGER_DATASTORE,CHANGER_INFO, CHANGE_TYPE) VALUES (?, ?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)], failed prior to DB execution due to exception: com.mercury.jdbc.sqlserverbase.ddc: [mercury][SQLServer JDBC Driver][SQLServer]Invalid object name 'HDM_140510INSTALL_1069639091'. : operation Model Update: Update model with bulk of operations in mixed OPTIMISTIC/STRICT mode

     

    Is this related to my previous problem?  I do not know how to resolve this.

  • Hi Adam,

     

    I apologize for my late response.

     

    Based on the error it appears to be a database issue.

    Can you state what is the error message when the Host Resources by WMI is failing? 

    Do you reindex your database if so how often do you do it, when was the last time?

     

    Regards,

    Ana Acosta-Diaz

Reply Children