Auto Complete Population

Is there a way to disable auto-complete for population job from ucmdb to ucmdb?

 

I've read that we can comment out this code in the adapter:

 

        <automatically-complete-reconciliation-info /

 

But this doesnt seem to work. 

 

I also see a setting for turning off auto complete but is for push.

 

            <adapter-setting name="push.autocomplete.reconciliation">true</adapter-setting>

 

Is there a same setting but for population?

  • You mentioned as

     

    "Is there a way to disable auto-complete for population job from ucmdb to ucmdb? "

     

     

    What does it mean ? Can you confirm what is the expectation of the above statement ?

  • When i populate ip_addresss and ip_subnet...auto-complete also pull in node and interface along with it. I believe this is due to the function of auto-complete reoconciliation. 

     

    I just want to populate ip_address and ip_subnet...nothing more

  • Hi,
    For Population from UCMDB to UCMDB, I think its controlled mostly by the TQLs you built, So you can try to built a TQL with only IP Address/Subnet.
    let me know, if this is what your question is
    Regards
    Ashok
  • My TQL is only consist of ip_subnet and ip_address

  • Hello,

    is there anybody that solved this issue? I would populated Node CI's from RTSM to UCMDB without attribute Primary DNS name. Even if the attribute is disabled in TQL, integration adapter still populate this attribute.

    I tried disable "automatically complete reconciliation" (comment) setting in adapter, also tried set it to false but nothings helps.

    Thanks for any hint.

    Ivan

  • Hello,

    You can control the behavior by configuring setting "population.autocomplete.reconciliation". It should be set on adapter similar to the one which is used by push flow.

    Hope it helps.

    Best  Regards,

  • Hello,

    in the adapter settings are two parameters, for push is:

    <adapter-setting name="push.autocomplete.reconciliation">false</adapter-setting>

    that works fine and I'm able control behaviour of integration with changing parameter.

     

    For population is:

    <automatically-complete-reconciliation-info/>

    I tried comment it or use following syntax:

    <!--<automatically-complete-reconciliation-info/>-->

    <automatically-complete-reconciliation-info>false</automatically-complete-reconciliation-info>

    <automatically-complete-reconciliation-info>disable</automatically-complete-reconciliation-info>

    but doesn't works, autocomplete is still active for population.

     

    If you know the correct syntax or how to disable it in the adapter please let me know. Thanks.

    Regards

  • Hello,

    Well I already mentioned how to disable it. You have to add the setting I mentioned. It was added from 10.33 I believe.

    The steps you mentioned will not do anything. Did you see those steps documented somewhere?

     

    Best Regards,

     

  • Hello,

    this parameter is already in the adapter config <automatically-complete-reconciliation-info/> that looks like it turned on.

    I didn't find any official document where is described how to manage auto complete reconciliation data for population job. If you know way how to do it please share with me exact statement that must by set in adapter config. Thanks.

  • Hello,

    There is no documentation for this as far as I know. However I do not understand why you focus on this tag <automatically-complete-reconciliation-info/> , Leave is as it is

    The adapter settings should be added to a different section in that xml file. Add the setting I mentioned in my first update. If you still cannot make it work then update your cmdb10xadapter xml file.

    Best Regards,