XML Enricher service will not start

I have a probe where the XML Enricher service will not start.  I've tried stopping / starting the service, rebooting the server and no luck.  Any ideas where to look to diagnose the issue?  Any help is appreciated.

 

Bob

Parents
  • What the does XML enricher log say?

    What's your version?

  • Thanks for the reply.  We are on 10.33 CP24 and the error log states:

     

    <2018-04-25 05:30:42,374> [WARN ] [XmlEnricherMonitorThread] (?:?) - Service UCMDB_Probe_XmlEnricher failed during starting up. Service NOT started.
    <2018-04-25 05:30:42,374> [WARN ] [XmlEnricherMonitorThread] (?:?) - Failed to start UCMDB_Probe_XmlEnricher!
    com.hp.ucmdb.discovery.probe.agents.probemgr.xmlenricher.services.ManageServices$ManageServicesException
     at com.hp.ucmdb.discovery.probe.agents.probemgr.xmlenricher.services.ManageServicesJNA.waitForStartPendingService(ManageServicesJNA.java:110)
     at com.hp.ucmdb.discovery.probe.agents.probemgr.xmlenricher.services.ManageServicesJNA.startService(ManageServicesJNA.java:75)
     at com.hp.ucmdb.discovery.probe.agents.probemgr.xmlenricher.services.XmlEnricherService.startSrv(XmlEnricherService.java:45)
     at com.hp.ucmdb.discovery.probe.agents.probemgr.xmlenricher.XmlEnricherMonitorService$XmlEnricherMonitorThread.startXmlEnricherServices(XmlEnricherMonitorService.java:462)
     at com.hp.ucmdb.discovery.probe.agents.probemgr.xmlenricher.XmlEnricherMonitorService$XmlEnricherMonitorThread.run(XmlEnricherMonitorService.java:451)

  • Difficult to tell.

    If you upgraded to 10.33 and jumped through multiple UCMDB versions, you could have some inconsistencies on configuration level.
    Does it create a dump file?

    The JVM dies also? Do you have an orphan process?

  • Did you perform an upgrade recently?  CUP upgrade? If so the xmlenricher port on the probe could be have a conflict. I changed mine from 34545 to 34546 and the enricher started.

  • Hi 

    I am also facng the same problem. recently i upgraded from cp25 to cp26. And on one of the probe XML Enricher service is not getting started.

  • How you chnaged the port number i mean from which file?

Reply Children