UCMDB Browser Service Modelling

Currently in the process of trialing using UCMDB 10.20 with Browser 4.01 in order to test service discovery. Within our test environment I've been using the URL for UCMDB front page ie http://servername.domainname:8080 or https://servername.domainname:8443.

So far the discovery creates the Business Service, creates links to the URLEndpoint and ConfigDocument but never gets any further. Yet I know UCMDB has discovered itself along with the probes, the server for the Browser and the Server for Config Manager as well as the Database servers.

Is there any reason why the Browser is unable to display anything beneath the Business Service layer?

 

I'd like to prove that this type of discovery would be beneficial within our organisation so would like to see the full power of this in operation but presently everything I've tried as the starting point for a Business Application fails to ever drill down as far as any servers or databases etc.

  • You should really run this against a weblogic URI, websphere URI, JBoss URI, Apache URI, IIS URI, etc.  It depends a lot on configuration files being in default places.  You will have better luck this way.

  • Hi Keith,

     

    Thanks for the reply. I've tried running the Service discovery again this time using a different URL. This one was based upon an IIS application. I entered the URL endpoint and ran discovery. This again created a small number of CIs mainly around the Business Service and configDocument. Still no relationship shows between the Business Service and the Windows CI or IIS Website etc.

     

    Also when running discovery within the Browser it says there are errors in discovery but the Browser never shows any of the errors so you have to keep going into UCMDB itself in order to see what these errors are. Is there any reason why the Browser doesn't display any of the errors?

     

    Thanks,

     

    Dave

  • You should be able to see the errors in the browser.  There's a checkbox to tick.  Have you seen the ASM Service Modeling presentation on the HP Live Network?  It is here:  https://hpln.hp.com/node/23292/attachment  please see if it helps you.

  • I've tried looking for the checkbox but not sure where its located, please could you let me know where its meant to be.

     

    Also I've found one or two strange anomolies when using the browser. For instance when I first click on a business service I get the full menu of options appear like Overview, Environment etc.

     

    I click on Environment it takes me in to show network and any other CIs related to it.

     

    I go back out and the then click on the menu button and number of options has disappeared like Environment.

     

    I've attached a document showing the menu issue and also the second screenshot shows as far as Service Discovery will ever drill down to.

     

     

    Browser 4.01 issues.zip
  • I couldn't see from your screenshot the user you are logged in as.  The discovery errors should be listed under the discovery tab.  To see the service model, you may need to show the layers or create new layers that show details of the service model.  It might be worth it to chat with your sales rep to have your Solution Architect for your account go through all of this with you.  I think this discussion is getting a bit heavy to support over messages on a message board, and you probably should either chat with your solutions architect or log a case to make sure everything is working correctly in this automated service modeling system.

  • Thanks Keith,

     

    In which case I'll raise a support case and go from there. As I'd like to make this work if it could provide some reall business benefit to our Business Service discovery work which is presently on-going. As a lot of this work is manual driven the idea of being able to use some additional discovery activities would certainly help :-)