CSV Import in ucmdb 10.33

All

I am doing a import via csv file in ucmdb 10.33. When I create a integration point and run it I get an error "Error message is: NTCMD: Connection failed".  I have given the data flow probe name and trigger ci instance at ntcmd.

Any inputs here ?

  • I am using "Import from CSV" adapter.

  • My guess is that you are trying to point to CSV file in a location different than a probe. As result probe is trying to connect to a remote destination and failing with credentials issue.

    In case my guess is a correct one, try moving the file to the local folder on the probe.

  • Hi Dmitry

     

    I doublechecked but the file is on the probe only. I have given the Data Flow Probe name and the trigger CI instance of the probe. I tried changing the location of file as well but same error.

    Can I perform any other troubleshooting steps ?

    Thanks so  much!

  • <execution jobId="DS_Test- Import topology from csv_Import topology from CSV File" destinationid="43c886dd244ee37687dae4e326ccd5c2" max_store_sent_results="2147483647">
     <destination>
      <destinationData name="hostId">4b82c89defa611829db6e8c84e4dff9c</destinationData>
      <destinationData name="credentialsId">44_1_CMS</destinationData>
      <destinationData name="ip_address">10.86.17.155</destinationData>
      <destinationData name="id">43c886dd244ee37687dae4e326ccd5c2</destinationData>
      <destinationData name="Protocol">ntcmd</destinationData>
      <destinationData name="connected_os_credentials_id">NA</destinationData>
     </destination>
     <params>
      <param param_name="JOB_ID" param_value="DS_Test- Import topology from csv_Import topology from CSV File" />
      <param param_name="processWithBinaryMode" param_value="false" />
      <param param_name="csvFile" param_value="D:\IT\abc.csv" />
      <param param_name="fileEncoding" param_value="UTF-8" />
      <param param_name="mappingString" param_value="" />
      <param param_name="skipEmptyValues" param_value="" />
      <param param_name="flushObjects" param_value="false" />
      <param param_name="defaultOwner" param_value="" />
      <param param_name="bulkSize" param_value="2000" />
      <param param_name="mappingFile" param_value="swr.xml" />
      <param param_name="taskType" param_value="runNow" />
      <param param_name="rowToStartIndex" param_value="1" />
      <param param_name="delimiter" param_value="," />
      <param param_name="maxThreadRuntime" param_value="900000" />
      <param param_name="ciType" param_value="node" />
      <param param_name="quoteSymbol" param_value="&quot;" />
     </params>
     <log start="14:29:43" severity="info">Execution current time:2018/09/26 14:29:43</log>
     <log start="14:29:43" severity="debug">NTCMD: Connection failed

    Traceback (most recent call last):
      File "csv_import", line 83, in DiscoveryMain
      File "import_utils", line 264, in importCis
      File "import_utils", line 248, in getCiMappingFactory
    NullPointerException: java.lang.NullPointerException
    </log>
     <log start="14:29:43" severity="debug">Reporting error code 200 to framework.</log>
     <log start="14:29:43" severity="debug">Error message is: NTCMD: Connection failed</log>
     <log start="14:29:43" severity="info">Execution current time:2018/09/26 14:29:43</log>
    </execution>

  • It's an import adapter because the job name is prefixed with DS_

    The NullPointerException is thrown at   File "import_utils", line 248, in getCiMappingFactory

    def getCiMappingFactory(Framework):
        mappingFileName = Framework.getParameter(PARAM_MAPPING_FILE)
        if mappingFileName:
            return CiMappingConfigUtils.getCiMappingConfigByFilename(mappingFileName)
        mappingString = Framework.getParameter(PARAM_MAPPING_STRING)
        ciTypeName = Framework.getParameter(PARAM_CI_TYPE_NAME)
        if mappingString:
            return CiMappingConfigUtils.getCiMappingConfigByMappingString(mappingString, ciTypeName)
        raise ValueError, "Neither of %s, %s parameters specified" % (PARAM_MAPPING_FILE, PARAM_MAPPING_STRING)

    So the if statement doesn't complain that would mean the file exists on the disk and there are permissions to access it or to read it. The return for the if stetment fails, this is line 248 in the error.

    CiMappingConfigUtils is imported from an internal library (com.hp.ucmdb.discovery.library.communication.downloader.cfgfiles) .
    Does the user which starts the probe service has sufficient rights to handle the mapping file?

  • CSV Import adapter can't work with local files. Even if the csv file is on the probe, you have to create discovery  with ntcmd or powershell, give the probe's shell CI as trigger and then import the file.

    Cheers,

    Petko Popadiyski

    Freelance Microfocus CMS UCMDB Consulting

  • Hi Petko

     

    I am using the probe name and Trigger CI instance as well but still it is giving me the same issue. Please see the attached screesnhot( I have edited few fields since it's a public forum).

     

    Thanks

  • Hey TChalla, 

    as Bogdan has said, the error is connected with where you have put the mapping file swr.xml. Can you verify where you can find it on the dataflowprobe?

     

     

  • Hi Bogdan/Petko

    The file is on the probe  at two location  

    D:\hp\UCMDB\DataFlowProbe\runtime\probeGateway\discoveryConfigFiles\abc.xml

    D:\hp\UCMDB\DataFlowProbe\runtime\probeManager\discoveryConfigFiles\abc.xml

    Do I need to mention the complete path in the integration point or it should pick up automatically from here. Is this correct