uCMDB Browser 4.01.87 Installation not connecting with uCMDB 10.20

Installed uCMDB Browser and getting an error when connecting to uCMDB server:  unable to connect to UCMDB server.  The log files previously showed that the error was coming from the wrong integration user credentials.  I created the credentials.txt file to update the credentials.bin file and that error has been replaced with the following error message:


Unknown error on UCMDB connection for connection: server: myucmdbserver, customer: N/A
java.lang.NullPointerException (I replaced my server name with myucmdbserver).


I'm not sure what to do now.  Any suggestions from anybody that's successfully installed the browser. 



  • I'm seeing this error also:

    Fail during login
    java.lang.RuntimeException: Ucmdb connection is not initialized


    Maybe this might indicate where the problem lies...


  • Sharon,


    The integration user you set in the <Browser Install DIR>/conf/credentials.txt file has to be the super integration user

    In the JMX Console, go to UCMDB-UI:name=UCMDB Integration and use setCMDBSuperIntegrationUser to set the super integration user.

    Once that is set, verify that <Browser Install DIR>/conf/credentials.txt no longer exists after starting up Browser and that <Browser Install DIR>/conf/credentials.bin is updated.


    Feel free to reach out,

  • Sharon,


    There are known issues with Browser 4.01 like the inability to submit credentials on the login screen


    If you are seeing this issue,  Browser 4.00 is stable and Browser 4.02 addresses this issue.

  • Thanks for the responses.  Since this was in my test environment, I reinstalled uCMDB 10.20 and the browser is installed as part of that installation.  I was able to get uCMDB Browser to work without any issues.  I must have messed up the OOB installation when I installed the browser separately.  What's a little strange is that the documentation doesn't mention anything about the browser being installed as part of uCMDB 10.20 (or I missed reading that).

  •  I am having the same issue, but only on Windows 2012 R2.

    The same setup works fine on Windwos 2008 R2.


    I removed version 4.02 and installed 4.00 but the error is still the same:


    2015-08-11 14:49:22,980 ERROR [pool-1-thread-1] UcmdbConnectionImpl - Unknown error on UCMDB connection for connection: server: myIP, customer: N/A
    at com.hp.ucmdb_browser.tomcat_config.persistence.files.AbstractUserCredetialsFile.extractBeanFromProperties(AbstractUserCredetialsFile.java:28)
    at com.hp.ucmdb_browser.tomcat_config.persistence.files.AbstractUserCredetialsFile.extractBeanFromProperties(AbstractUserCredetialsFile.java:13)
    at com.hp.ucmdb_browser.tomcat_config.persistence.files.PropertiesBasedPersistentFile.read(PropertiesBasedPersistentFile.java:26)
    at com.hp.ucmdb_browser.tomcat_config.persistence.files.SuperIntegrationUserFile.getFilePath(SuperIntegrationUserFile.java:25)
    at com.hp.ucmdb_browser.tomcat_config.fileutils.PersistenceFilesUtils.load(PersistenceFilesUtils.java:32)
    at com.hp.ucmdb_browser.server.ucmdb_connection.UcmdbConnectionImpl.getCredentials(UcmdbConnectionImpl.java:274)
    at com.hp.ucmdb_browser.server.ucmdb_connection.UcmdbConnectionImpl.initialize(UcmdbConnectionImpl.java:144)
    at com.hp.ucmdb_browser.server.ucmdb_connection.UcmdbConnectionManager.getUcmdbConnection(UcmdbConnectionManager.java:41)
    at com.hp.ucmdb_browser.server.configuration.CustomersRetrieverInitializerBean.retrieveAllConnectionsPerCustomer(CustomersRetrieverInitializerBean.java:103)
    at com.hp.ucmdb_browser.server.configuration.CustomersRetrieverInitializerBean.access$000(CustomersRetrieverInitializerBean.java:39)
    at com.hp.ucmdb_browser.server.configuration.CustomersRetrieverInitializerBean$1.run(CustomersRetrieverInitializerBean.java:63)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

  • Embedded Browsers should not have connection issues so I'm assuming its a separate instance.

    There are a few possible reasons:
    1. ucmdb_browser_config.xml is not properly configured with UCMDB host name and/or port

    2. Super Integration User has been changed from OOTB which is the UISysadmin. UCMDB Browser uses UISysadmin to connect to UCMDB. Set the new Super Integration User with a credentials.txt file in /conf/

    3. The password for UISysadmin has changed, set the new password in credentials.txt in /conf/

    4. Network rules preventing communication between the Browser and UCMDB server on the required ports


  • Hi Rey


    It is not an embedded Browser, it is a stand-alone installation on a seperate server from the UCMDB server.


    1. ucmdb_browser_config.xml is configured with the hostname and port, I tried the FQDN and the IP

    2. and 3.: The Super Integration User was changed and the username and password was set in the credentials.txt in /conf/

    4. There are no network rules preventing communication. There are no firewalls preventing communication, only the Windows firewall, but this has been disabled. I can telnet from the UCMDB Browser server to the UCMDB server on port 8080.


    Kind regards


  • Jacob,


    1. I would set the Super Integration User again in the JMX to the new Super Integration User you've set.

    2. Remake the credentials.txt file again


    Frst set the Super Integration User 

    This is done in the UCMDB JMX

    UCMDB-UI:name=UCMDB Integration


    Use the setCMDBSuperIntegrationUser method

    enter the username and password and click on Invoke


    Then go to your UCMDB Browser server.

    Using a text editor like notepad create a credentials.txt file in [Browser]\conf\

    the contents of the file is just

    user=UISysadmin (or your custom Super Integration User)


    Save the file and restart UCMDB Browser
    You'll see the credentials.txt file is gone after startup and the credentials.bin is updated


    If this doesn't work, are you using HA for UCMDB or Browser?

  • Dear all,

    we had the same issue upgrading to UCMDB Browser 4.03. Rey Lejano's suggestion solved the issue. Just keep in mind that there are two encryption.bin files, one located to [Browser]\conf\ and another one located to C:\Program Files (x86)\Apache Software Foundation\Tomcat 7.0\conf. Create the credentials.txt under  [Browser]\conf\ as reported above.



  • Hi Rey.

    I am facing the same problem.

    My problem however is that the uCMDB Browser is sitting on the same server as the uCMDB server(embedded).

    The error I receive on the UI is : Failed to connect to uCMDB server.

    What could be the problem? I have tried updating the ucmdb_browser_xml, restarted the uCMDB server, but the same error.

    Version of uCMDB Browser is 4.04, uCMDB is 10.22