<UCMDB Support Tip> Manually upgrade the SNMP4J library to version 2.5.11

UD SNMP client in CP27 is compiled based on SNMP4J version 2.5.11, which is incompatible with the previous SNMP4J in the SNMP Version 3 (SNMPv3) part. You need to manually upgrade the SNMP4J library to version 2.5.11 in Data Flow Probe if SNMP Protocol uses SNMPv3 and works in CP27 that is installed on UCMDB 10.22 (with a CUP), 10.33 (with a CUP), or 11.0.


Here are the steps:
1.Download SNMP4J from http://www.snmp4j.org/html/download.html.
2.Extract snmp4j-2.5.11-distribution.zip.
3.Rename snmp4j-2.5.11.jar in the snmp4j-2.5.11\dist folder to snmp4j.jar, and then copy this file to the <DataFlowProbe_Home>\content\lib folder.
4.Backup current "local_policy.jar" and "us_export_policy.jar" which are under <probe_installation>\bin\jre\lib\security
5.Download jce_policy-8.zip from offiical website. http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
6.Unzip this jce_policy-8.zip and replace the "local_policy.jar" and "US_export_policy.jar" jar files in Probe installation path <probe_installation>\bin\jre\lib\security
7.Restart probe service.