NTCMD Issue

Hello,

 

I have tried what i mentionned in http://support.openview.hp.com/selfsolve/document/KM00867941 about NTCMD issues on Windows 2008 R2 ....

 

1/  HPCMD.bat issues with  log4j erros (cannot open pipes)

2/ admin$ share results with success

3/ i have add new key "SCMApiConnectionParam" with "0x80000000" param

4/ i try to use compatibility mode with "Windows XP (Service Pack 2)" but this mode is not listed ... only have vista, 7, 2008 SP1 ....

 

Any help would be appreciated

 

thanks

  • Hello Esposito,

    This seems to be an issue of windows and not UCMDB, if the option is not available then I would suggest contacting Microsoft
  • Hello

    We've seen similar issue before, but the information is not enough for me to be 100% sure if it's the same issue. 

    You can first give a try. I copy the problem and solution here.

     

    Root cause

      It seems to be a known issue of Microsoft. I copy the reference below

      http://support.microsoft.com/kb/2628582

      The named pipe is created by hpcmdsrv correctly, but not connectable due to this defect.

     

    Solution

      2 solutions mentioned in the reference:

      1 : apply a hotfix.

        After testing with customer, we think that the hotfix should be applied to all target device to discover.

        Because the named pipe is created on the target device and need to be accessed.

        So it become a little difficult to apply.

      2 : disable the SMB2 protocole.

        We've also tested this, it works well if we just disable SMB2 on probe side. All communication is based on SMB1 and the problem don't reproduce.

     

    Suggestion

      we suggest customer to stay with the solution 2.

      Here is the reference to disable the SMB2.

      http://support.microsoft.com/kb/2696547

     

      To sumarize, the following 3 command need to be run:

      Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB2 -Type DWORD -Value 0 -Force

      sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi

      sc.exe config mrxsmb20 start= disabled