Integration with Atrium

Hello,

 

We set an integration point to populate RTSM from Atrium.

The integration works well for Cis, but not for links. RTSM when querying Atrium doesn't retrieve link whereas there are links between objects (Computer system and IPEndpoint ) in Atrium.

 

Here what we get from the probeMgr-adaptersDebug log:

 

  Query data for: Class <BMC_ComputerSystem>, Namespace <BMC.CORE>, Query <Company="IPSEN" AND TEL_AdresseIP!="" AND TEL_AdresseIP!="Service">, Attributes List <['Name', 'SerialNumber', 'ManufacturerName', 'Model', 'Type', 'TokenId', 'TEL_PID', 'Site', 'TEL_ReportingLibre1', 'TEL_ReportingLibre3', 'TEL_ReportingLibre4', 'TEL_OrganizationOutilsLevel11', 'TEL_OrganizationOutilsLevel12', 'TEL_OrganizationOutilsLevel13', 'TEL_OrganizationOutilsLevel14', 'TEL_OrganizationOutilsLevel21', 'TEL_OrganizationOutilsLevel22', 'TEL_OrganizationOutilsLevel23', 'TEL_OrganizationOutilsLevel24', 'Category', 'Item', 'Company', 'TEL_AdresseIP']>, Children List <[]>, Parent List <[]>
<2015-04-21 10:25:17,454> [INFO ] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - Retrieved 1122 objects of type BMC_ComputerSystem
<2015-04-21 10:25:17,456> [INFO ] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - Query data for: Class <BMC_IPEndpoint>, Namespace <BMC.CORE>, Query <Company="IPSEN" AND Address!="Service">, Attributes List <['Address']>, Children List <[]>, Parent List <[]>
<2015-04-21 10:25:20,420> [INFO ] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - Retrieved 1144 objects of type BMC_IPEndpoint
<2015-04-21 10:25:20,421> [INFO ] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - Query data for: Link <BMC_Dependency>, End1 Class <>, End2 Class <>, Namespace <BMC.CORE>, Query <None>, Attributes List <[]>
<2015-04-21 10:25:20,455> [INFO ] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - Retrieved 0 links of type BMC_Dependency
<2015-04-21 10:25:20,691> [INFO ] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - End atrium_query.py
<2015-04-21 10:25:20,692> [DEBUG] [JobExecuterWorker-0:DS_Atrium to BSM_Import data from Atrium] - Finished script atrium_query.py

 

 

Would you help us find the cause of this issue ?

 

Thanks!

fzomafo

  • Hi fzomafo,

     

    Can you please provided your RTSM version by providing the output from:

     

    Mbean: UCMDB:service=Server Services. Method: viewSystemInformation

     

    Obtained after logging to the JMX console of RTSM (http://<bsm-dp-servername>:21212/jmx-console default user/password are admin/admin)

     

    What is the Atrium version?

     

    Regards,

    Paula

  • Hello Paula,

     

    here are system information:

     

    *** System information ***
    Server version: 9.05.CUP130 build: 65
    OS: Windows Server 2008 R2 version 6.1
    DB: BSM_RTSM at SQLServer on VIP-MSSQLRPTROC:1433 with userName
    CP: 11.09.811
    HA: No servers found.
    Customers [Total of 1 customer(s)]:
    [Customer ID: 1, Name: Default Client, Cluster ID: null, Description: Default Client, Config ID: 22
    Probe: BSM-UDRPTROC, version: 9.05.CUP130, build: 65

     

    Atrium version: 8.1

     

    Best regards,

    fzomafo