Cannot create Management Zone

We have a client with a freshly installed UCMDB v10.21 CUP 1 and Configuration Manager v10.21 CUP 1 environment on Windows 2012 R2.  I have a problem creating Management Zones.  When I enter the parameters in the dialog and click OK, nothing happens.  I can see the memory increase in the background, but nothing is added and nothing locks up in the interface.  I simply hit Cancel and go back to the main UCMDB screens.  The UCMDB server throws a couple of rather useless error messages in the err.log file (added below), but they don't tell me much.

Now the bad news.  This client has restrictions on browsers and Java versions.  I'm stuck with IE 11 and Java v7 u51.  Yes, I know both are unspported.  I have the IE 11 workaround recommended by HP in place that is allowing us into the application, but there's currently nothing I can do about the Java version.  The weird thing is, I can't recreate the problem in my own development environment using this same configuration.  Same server OS, same app software, same browser and Java - no errors.

I tried creating the Management Zone through the JMX console and the system said it worked.  I got no new errors in the error.log file.  However, when I log back into UCMDB, the interface refuses to display the Data Flow Probe Setup or Universal Discover screens, which means I can't verify the Zone creation or actually do anything with it if it's there.

This is a really convoluted problem, with a lot of variables, but does anyone have any ideas of where to look or what to try?

The error.log entries (edited to shorten them):

2015-11-27 16:06:33,201  ERROR  [qtp1809491926-36650] ( - Error while invoking service. (DiscoveryService#UcmdbMethod)
java.lang.Exception: Wrong request
    at org.springframework.remoting.httpinvoker.HttpInvokerServiceExporter.handleRequest(
    at org.springframework.web.servlet.mvc.HttpRequestHandlerAdapter.handle(


2015-11-27 16:06:33,292  ERROR  [qtp1809491926-36650] ( - Error while invoking service. (DiscoveryService#getManagementZoneById)
    at sun.reflect.GeneratedMethodAccessor403.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(


  • It's a long shot, but here's an update in case it triggers anyone's ideas on this.

    I have one dev system that is installed in an identical manner to the troubled system.  Same OS, same architecture, same software versions and same client browser and Java version.  On this system, I can create Management Zones with no problem.  I checked the cmdb_api_audit_detailed.log file on both systems after trying to create a Management Zone.  On the working system, I can see API calls to check permissions followed by a SaveManagementZoneRequest call to create the new Zone.  This is then followed by addtional permission requests and a LoadManagementZoneByIdRequest call, I assume, to update the interface for the user to see the new Zone.

    On the trouble system, I see no attempt at a SaveManagementZoneRequest call.  The system goes straight to the LoadManagementZoneByIdRequest which, of course, fails since no Zone has yet been created.  Anyone have any thoughts?  Anyone?

  • Still no solution on this problem, but we have established that there is a problem either at the client side or between the client and the UCMDB server.  We got the same Java version installed on the UCMDB server and tried configuring the Management Zone locally with no problems.

  • Verified Answer

    The problem turned out to be an undeclared firewall between the UCMDB server and the client machine we were given to communicate with it.  Something in the configuration allowed some traffic through but not all so we got inconsistent behaviours in the client.