Idea ID: 2703261

Not able to associate same CI twice using Assisted Templates from CMS Brower

Status : Waiting for Votes
Waiting for Votes
See status update history
over 1 year ago

We have created several modeling queries (assisted templates) in UCMDB for customer to create Service models.

However, the main issue (or product limitation it seems) is the same CI cannot be related multiple times within the same model if the purpose if CI is different. e.g. using the same functional group to be associated twice using two different link types e.g. Ownership, Responsibility which shows different purpose of functional group with the associated CI.

We have created quite sophisticated model for customer to define business services and their attributes (correct relationships) with other CI types in a consistent manner using 'Assisted modeling' feature from CMS Browser.

This feature uses the predefined queries and build a CI model in a specific designed patter defined by query.

However, issue is, within same model, a same CI cannot be related multiple times even if relationship type is different.

Once CI is associated with another CI in the model, the only option it presents is to remove that CI from model instead of adding them again with a different relationship type.

A support case was raised but been advised by support team to raise this idea exchange for them to assess and update existing feature to include this feature.

For the purpose of reproduce issue, I have created a very simple model (query) to explain the issue.
The attached model (screenshot and UCMDB query), is to create a "business service" with defined links to a 'default ConfigAdminGroup' and 'Support Groups'.
ConfigAdminGroup and SUpport group are referring to 'Functional Group' CI Type.

Now, in an instance where business service has a same functional group as DefaultConfigAdminGroup as well as Support group, I can't define both as relationship using template since I do not get the 'Add' on the functional group CI again if it is already appearing in the model.

Screenshot shows the example where:
1) Business service called 'demo01' is created at the bottom layer
2) Functional Group called 'Hardware' is associated as 'ConfigAdminGroup' i.e. the default group for CI (if you look in Service Manager)
3) There's a third bod called 'SupportGroups' where one or more FunctionalGroup CIs can be added.
4) When I try to add 'Hardware' again as the 'SupportGroup', I do not get the 'Add' button on the CI to push it onto model. I instead get the 'remove' button which, if pressed, will remove the earlier association made in point no. 2) above.

Issue is not limited to Business Service v/s Functional Group CI association. Example is used to easily demonstrate the problem. This problem is generic where same CI cannot be associated more than once in the same model.

Attached is the screenshot with 'Yellow' highlights showing the problematic area and I am also attaching the temporary query created to demonstrate the problem.

We are using below version but it is not limited to this version only.
UCMDB Version 2018.08
CMS Browser version 2018.08
Browser - IE11 , Firefox , Chrome (all three tried)
Client OS - 2012 server, Win 10, 2016 server (all three tried)
Server OS - Win server 2012 R2

Custom Query name - BusiniessServiceSupportGroup
Query path - UCMDB Browser -> Queries
Query exported as XML format.



  • Thank you for sharing your idea! It’s open for comments and kudos, and we’re looking forward to input from the community. Once there is enough community traction, it will be further reviewed by the product team